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304 PHOTOSHOP 6 TIPS
Written by Trevor Morris ( tmorris@fundy.net | http://user.fundy.net/morris/ ) 

Part of what makes Photoshop such an incredibly powerful and pleasurable program to use is its well-
thought out implementation: the interface is polished and uncluttered and easily customizable (despite 
its vast arsenal of tools and commands). In fact, there is a surprising amount of "hidden" functionality 
within Photoshop; so much so, that despite the number of years you work with the program, you will 
undoubtedly keep discovering more and more about it. I doubt anyone could claim that they know 
"everything" about Photoshop (except maybe Adobe's software engineers ;-). 

The tips below should help you (whether you are a beginner or a seasoned expert) to harness some of 
Photoshop's "hidden" functionality to streamline your work, perform complex tasks more quickly or 
efficiently, or teach yourself something you had no idea Photoshop was capable of! 

Here are a couple of notes before you begin: 

l I tend to prefer hotkeys (e.g. [Ctrl+D] ), but I have provided equivalent alternatives (e.g. Select » 
Deselect - which denotes a menu command) wherever possible 

l Mac users: Ctrl = , Alt = Option (e.g. Ctrl+Alt+D = �Option�D); right-click = Control�click 

For your convenience, the tips have been organized into the following categories: 

Interface Tips

Tool Tips

Command Tips

Filter & Style Tips

Layer Tips
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INTERFACE TIPS 

APPLICATION WINDOW 

DOCUMENT WINDOW 

1. Use the Zoom field (  in the bottom-left of the Photoshop window or Navigator palette) to 
enter an exact zoom level.

Tip: Press Shift+Enter after entering a value to have the field remain active. 

2. To change the information displayed in the status bar (which, by default shows document sizes), 
click on the  button and choose an option from the pop-up menu. You can also click on the status 
bar (to the left of the  button) to display the print size of the current document. Alt-click to see the 
image dimensions and resolution, or Ctrl-click for tile information. 

Tip: Choosing Document Profile from the status bar menu (  ) will allow you to monitor the color 
space of any / all documents opened in Photoshop. 

3. Double-clicking on Photoshop's background (the gray background) will summon the Open command 
[Ctrl+O] (File » Open). 

4. You can fill the (gray) canvas borders with the foreground color by Shift-clicking 
on it with the Paint Bucket tool [G]. 

Note: To replace the default color, change the foreground color to 25% gray 
(R192,G192,B192) and Shift-click on the canvas border again. 

5. Press "F" to cycle between three different full screen modes (or use the  buttons near the 
bottom of the toolbar). 

Tip: Press Shift+F to toggle the menus in full screen mode. 

Tip: Shift-click on one of the screen mode buttons (  ) in the toolbar to display all open 
documents in the selected mode. 

6. Right-click on an image window's titlebar to quickly access features like Canvas Size, Image Size, 
Duplicate and File Info. 

7. Pausing the mouse pointer over an image window's titlebar will reveal (via a tool tip) the full path of 
the current document. 
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8. To mark your image as copyrighted, choose File » File Info and in Copyright & URL [Ctrl+6]. Check 
the Mark as Copyrighted option and enter any relevant information in the fields provided. Press the 
OK button and note the copyright symbol ( © ) that appears in front of the image title in the 
document title bar. 

Tip: You can even save this information and load (or append) it later for inclusion in another image. 

Tip: Right-click on a document titlebar to quickly access the File Info command. 

9. Sometimes it is quicker to navigate with the keyboard than to reach for the mouse. Here are some 
useful navigation keys:

HotKey Result

Home / End go to top-left / bottom-right corner of the canvas

PageUp / PageDown scroll canvas up / down one page

Shift+PageUp / PageDown scroll canvas up / down 10 pixels

Ctrl+PageUp / PageDown scroll canvas left / right one page

Ctrl+Shift+PageUp / PageDown scroll canvas left / right 10 pixels

10. Use Ctrl+Tab (or Ctrl+F6) and Ctrl+Shift+Tab (or Ctrl+Shift+F6) to activate the next and previous 
documents, respectively. Alternatively, you may choose a document, by name, from the (bottom of 
the) Window menu. 

11. The title bar of a Photoshop document contains a wealth of information about the image, but not all 
of it is self-explanatory. Here is a sample title bar: 

 

1. If the current image is copyrighted, a copyright symbol ( © ) precedes the document name. See 
File » File Info: Copyright & URL [Ctrl+6] to see more information about the copyright. 

2. Next is the name of the document (e.g. Untitled-1.psd, MyImage.gif, etc.). 

3. Immediately following the document name is the magnification (viewing size) for the current 
image (e.g. @ 100%, @ 66.7%, etc.). 

4. After that, beginning in brackets, is the current layer name (e.g. Layer 1). 

Note: If the current document is a flattened image containing only a Background layer, no layer 
name is displayed in the title bar. 

5. The color mode of the document follows (e.g. RGB, CMYK, etc.). 

Note: the color mode will be preceded by a comma ( , ) if a layer name is present (see previous). 

6. If a pound symbol ( # ) appears after the color mode, it means that the document is untagged 
(i.e. it is not color-managed). An asterisk ( * ) after the color mode implies that the document 
colorspace is different from the working colorspace. The absence of these symbols means that the 
colorspace of the document matches the working colorspace. 
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PALETTES 

7. After that (and preceded by a slash [ / ]) is the soft-proofing mode (e.g. CMYK, Monitor, etc.) - if 
soft-proofing is enabled [Ctrl+Y] (View » Proof Colors). 

Note: When converting profiles (Image » Mode » Convert to Profile) this area will display the word 
Preview - provided that Preview is enabled in the Convert to Profile dialog box. 

12. Use the Mouse Wheel over the canvas to zoom in (up) and out (down). 

13. To reset all palettes to their default locations, choose Window » Reset Palette Locations. 

14. To reset the contents of an individual palette, choose the Reset command from the respective 
palette's menu (  ).

Note: The reset command is not available for all palettes. 

15. Press the Tab key to hide the toolbar and all palettes. Press Shift+Tab to hide only the palettes 
(and leave the toolbar visible). 

Tip: To reveal the Options palette (Window » Show Options), even when all other palettes are 
hidden, simply press the Enter key. 

16. Snap your palettes to the nearest screen edge by Shift-dragging them or Shift-clicking on their 
titlebars. 

17. For palettes that contain thumbnails, right-click on an empty area of the palette to reveal a context 
menu that allows you to choose from the following thumbnail sizes: None (which is not always 
available), Small, Medium and Large. 

Note: This applies for the Layers, Paths, and Channels palettes in Photoshop and the Layers, 
Rollover, and Animation palettes in ImageReady. 

18. Increase / decrease slider bars by 1% using the left / right arrow keys. Add 
Shift to increase / decrease by 10% increments. 

19. Right-click on thumbnails in the Layers palette [F7] (Window » Show Layers) to display a context 
menu of available commands - this is especially useful for layer masks and layer clipping paths. 

20. Minimize palettes by double-clicking on their associated palette tabs. Use the minimize button (  ) 
on the palette titlebars to cycle between compact mode (minimum number of options / contents 
visible) and contents mode (view all palette options / contents). 

Note: You can also double-click the toolbar's titlebar to minimize it. 

21. Press Shift+Enter in palette fields to apply the current value but have the field remain active. This 
is a quick way to experiment with different values. 

22. Alt-click on a triangle icon (  ) to expand or collapse all child elements of an action, layer style, or 
layer set. 
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23. You may "stack" palettes (example) by dragging one palette tab onto the top or bottom of another 
palette: a highlight appears to indicate where the palette will be placed. 

Tip: You may also group palettes together by dropping one palette onto the middle of another. 

24. Click on the background color well on the Color palette (not the toolbar) to have any color changes 
affect the background color. A black outline indicates the active color well. 

Tip: With the Eyedropper tool [ I ], press the Alt key to choose a color for the opposite color well. 
For example, if the foreground color is the active color well, press the Alt key to select a color for 
the background, and vice versa. 

25. Shift-click on the color ramp, in the Color palette [F6] (Window » Show Color), to change the 
spectrum. Alternatively, you may either right-click on the color ramp or open the Color palette 
menu (  ) to select an alternate color mode. 

26. Add a custom color to the Swatches palette (Window » Show Swatches) by clicking on any empty 
(gray) area. Remove a color by Ctrl-clicking on it. Replace a color by Shift-clicking on it. 

Tip: Choose a background color from the Swatch palette by Alt-clicking on the desired color. 

27. Ctrl-drag inside of the proxy preview area, in the Navigation palette 
(Window » Show Navigator), to specify a new view area within the 
current document. 

Tip: Shift-drag within the proxy preview area to move the highlight 
vertically and horizontally. 

Tip: Change the color of the proxy view highlight by selecting 
Palette Options from the Navigation palette menu (  ). 

28. Assume that you want to see the dimensions of the current cropping marquee, but the Info palette 
is hidden beneath another palette. You cannot click on the Info palette tab (or press F8) to bring it 
to the foreground: however, you can choose Window » Show Info to bring the palette to the 
foreground! 

Tip: To bring a palette to the foreground (of a palette group) while a dialog box is open (such as 
Curves, Levels, etc.), choose the palette name from the Window menu (e.g. Window » Show Info), 
or press its associated hotkey. 

29. To create a duplicate image of the currently selected history state or snapshot in the History 
palette (Window » Show History): 
l click the New Document button (  ) 
l choose New Document from the History palette menu (  ) 
l drag-and-drop the current state (or snapshot) onto the New Document button (  ) 
l right-click on the desired state (or snapshot) and select New Document from the context menu 

30. Drag a history state from the History palette (Window » Show History) of the current image into any 
other image window to replace the contents of the destination image. 

31. Alt-click on any history state (other than the current state), to duplicate it. The duplicated state 
becomes the current (most recent) state. 

32. Alt-click on the New Snapshot button (  ), at the bottom of the History palette, to display a 
dialog box that allows you to duplicate the current image as a Full Document, Merged Layers, or 
Current Layer. 

http://user.fundy.net/morris/images/tutorials/pstips/stackpalettes.gif
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DIALOG BOXES 

33. Use the up and down arrow (cursor) keys to change the values in entry fields and drop-downs. Add 
the Shift key to change the values by a larger increment. 

Tip: You can also use the Mouse Wheel to change values. Use Shift-Mouse Wheel to change the 
values by larger increments. 

34. To replace the current preset (i.e. brushes, swatches and shapes, etc.) without being prompted for 
confirmation, hold down the Alt key while choosing a preset from the Preset Manager or a palette 
menu (  ). 

35. When the Color palette [F6] is in Web-safe mode, Alt-drag the sliders to prevent them from 
snapping to the Web-safe tick marks. 

36. Click on palette field titles to highlight / select the contents within the field (or to 
turn checkboxes on / off). 

37. Hold down the Alt key to change any Cancel button into a Reset button (in any dialog box); this 
allows you to easily restore values without having to cancel and come back. 

38. For dialog boxes that contain multiple pages (e.g. Edit » Preferences » General), use Ctrl+N and 
Ctrl+P to go to the next and previous pages, respectively. 

39. Use the Favorites button (  ) in Open dialog box [Ctrl+O] (File » Open) 
to store folders that you visit on a regular basis. 

40. Use the hexadecimal color field ( # ) in the Color Picker dialog box to copy and paste color values 
from one place in Photoshop to another (or even to another application that supports hexadecimal 
color values). 

41. When selecting colors in the Color Picker dialog box or Color Palette [F6] (Window » Show Color), 
click on the Web-safe icon (  ) to force the selected color to the nearest Web-safe equivalent. 
Click on the Out of Gamut icon (  ) to force the selected color to the nearest print safe color. 

42. While using the Save for Web dialog box [Ctrl+Alt+Shift+S] (File » Save for Web), hold down the Alt 
key to change the OK button into a "Remember" button. Press this button to assign the current 
settings to the active document. These optimization settings will be remembered, even if you press 
Cancel. In addition, if you save the document, the assigned settings will be saved with as well. 
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TOOL TIPS

PAINT TOOLS 

1. To draw a straight line with any paint tool, click on the image, move the mouse, and then Shift-click - 
Photoshop will join the two points with a straight line using the current tool. 

2. While using any of the paint tools, press Enter to display / dismiss the Preset Picker (at the current 
mouse location). To access a list of available brush modes while painting, Shift-right-click on the 
image. To change the current brush / preset options, click directly on the brush / preset preview in 
the Options palette (or choose Edit Brush from the Shift-right-click menu). 

3. Use the Caps Lock key to turn Precise Cursors on / off. 

Note: This does not work if Precise Cursors are already enabled in the Preferences [Ctrl+K, Ctrl+3] 
(Edit » Preferences » Display & Cursors). 

4. Use the hotkeys in the following table to vary the brush for the current paint tool:

HotKey Result

[ / ] decrease / increase brush size

Shift+ [ / ] decrease / increase brush hardness by 25%

< / > previous / next brush

Shift+ < / > first / last brush

Enter display / dismiss Preset Picker

5. Use the options available in the Brush Dynamics button menu (  ), on the Options palette, to 

fade the size, opacity, and color of the various brush tools. 

Note: For people who use tablets, the above options may also be configured to recognize a stylus. 

6. With the Auto Erase options enabled for the Pencil tool [B], if you begin painting on an area that 
contains the foreground color, the background color will be used instead, and vice versa. This is 
really useful for cleaning up line art, since it alleviates the need to continuously switch between the 
Pencil [B] and Erase [E] tools. 

7. While using the Eraser tool [E], hold the Alt key to erase back to the source history state - similar to 
the behaviour of the History Brush tool [Y]. 

Note: You must establish a source history state in the History palette in order for this to work. 

8. When using the Smudge tool [R], hold the Alt key down to include the foreground color in the 
smudge. 

9. Use the Paint Bucket tool [G] to delete (instead of filling) by changing its blending mode to Clear 
[Alt+Shift+R] (in the Options palette). 

10. To fill the transparent regions of an image, choose Edit » Fill [Shift+Backspace] and choose 
Behind from the Mode drop-down. 
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SELECTION TOOLS 

11. Alt-drag color stops (color stop image), in 
the Gradient Editor, to duplicate them. 

12. Hold down the Alt key while using the Blur tool [R] to sharpen, or to blur while using the Sharpen 
tool [R]. 

13. Hold down the Alt key while using the Dodge tool [O] to darken, or to lighten with the Burn tool [O]. 

14. When using the Marquee tools [M], use the Shift key to create perfect circles or squares: use the 
Alt key to draw them from their centers. 

15. Use the Reselect command [Ctrl+Shift+D] (Select » Reselect) to restore your last selection. 

16. You may alternate between Polygonal and Freehand Lasso [L], while you are creating a selection, 
by holding down the Alt key. 

Example: See Selection Secrets 2 (Polygonal / Freehand Lasso) for a comprehensive description. 

17. Use the Space Bar to move a selection while drawing it. 

Example: See Selection Secrets (Moving Selections) for a comprehensive description. 

18. Hold the Shift or Alt keys to add or subtract selections, respectively. Hold down both Shift and Alt 
together to intersect two selections. 

Tip: Ctrl-click on a layer thumbnail (in the Layers palette) to load its transparency mask, and then 
Ctrl+Alt+Shift-click a second layer to intersect the two layers‘ transparency masks. 

Example: See Selection Secrets (Intersecting Selections) for a comprehensive description. 

19. Retain your selections while scaling or duplicating an image by first switching to Quick Mask mode 
[Q] (or click on the Quick Mask icon (  ) near the bottom of the toolbar). 

20. Alt-click the Quick Mask button to toggle between masked (  ) and selected areas (  ). 

21. After editing a selection in Quick Mask mode, Alt-click the Standard mode (Quick Mask off) button 
(  ) to invert the current selection. 

22. Ctrl-clicking on a layer thumbnail in the Layers palette is a convenient way to load the 
transparency mask for the active layer: however, if the contents of the layer extend beyond the 
edges of the canvas, so too will the resulting selection. To restrict the selection to the document 
bounds, invert the selection [Ctrl+Shift+I ] (Select » Invert) twice. 

http://user.fundy.net/morris/redirect.html?photoshop9.shtml
http://user.fundy.net/morris/redirect.html?photoshop8.shtml
http://user.fundy.net/morris/redirect.html?photoshop8.shtml
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23. By default the Select » Color Range command dialog box displays the entire image in the preview 
area. For a more accurate preview and greater control, create an approximate selection around 
the area of interest. The selected area will be displayed in the preview area. 

Tip: Hold the Shift key while choosing Select » Color Range to add the resulting selection to the 
current selection. Hold down Alt to subtract the results from the current selection. 

Tip: Hold down the Ctrl key to toggle between Selection and Image previews in the Color Range 
dialog box. Use the Shift key to add colors and the Alt key to subtract colors from the selection. 

Tip: Hold down Alt when choosing Quick Mask from the Selection Preview drop-down in the Color 
Range dialog box to adjust your Quick Mask Options without leaving the dialog. 

24. Use a selection to stroke only a portion of a path. 

25. When transforming a selection / layer, use the following buttons in the Options palette for added 
control: 

l use the "Reference point location" image (  ) to position the reference / pivot point 

l press the "Relative positioning" button (  ) to switch from absolute (canvas) positioning to 
relative positioning 

l press the "Maintain aspect ratio" button (  ) to maintain a 1:1 aspect ratio while transforming 

26. You can use the Marquee tool [M] (or Lasso tools [L]) to drag a selection outline from one 
document into another. 

Tip: Hold the Shift key down (after initiating the drag - after clicking with the left mouse button) to 
have the selection centered in the destination document. 

27. Here are some useful shortcuts for use with the Magnetic Selection tool [L] and Magnetic Pen tool 
[P]:

HotKey Result

[ / ] decrease / increase the Width

< / > decrease / increase Edge Contrast

Shift+[ / ] minimize / maximize the Width

Shift+< / > minimum (1%) / maximum (100%) Edge Contrast

Alt-drag Freeform tool

Alt-click draw straight lines

Alt+Shift-click draw straight lines at 45° increments

Alt-double-click close selection

Alt-double-click close selection with a straight line
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COLOR TOOLS 

28. When dragging selections or layers from one document to another, hold down the Shift to have 
them centered on the destination canvas. 

Note: If the source and destination documents are the same size (dimensions), the dragged 
elements are placed in the same relative position as they were in the original document (instead of 
being placed in the center of the canvas). 

Note: If the destination canvas contains a selection, the dragged item will be placed into the center 
of the selection. 

29. When using the Lasso tool [L], hold the Alt key to draw a selection beyond the canvas boundaries. 

30. To quickly change the Tolerance setting for the Magic Wand tool [W], press Enter, type the 
desired tolerance (or use the up and down arrow keys) and then press Enter again. 

31. Hold down the Alt key while using any paint tool to temporarily access the Eyedropper tool [ I ]. 

32. Hold down the Alt key when selecting a color with the Eyedropper tool [ I ] to define a background 
color. 

33. Use the Color Sampler tool [Shift+I ] with the help of the Info 
palette [F8] (Window » Show Info) to monitor color changes in 
the current image. The before / after color values are 
displayed next to their respective color sampler number (e.g. 
# 1). Specify the sampler color mode via the  pop-up menu 
on the Info palette. 

To add a new color sampler simply click anywhere on the 
canvas (with the Color Sampler tool). Remove a sampler by 
Alt-clicking on it. 

Note: You may only have a maximum of four color samplers 
per image. 

Tip: To use the Color Sampler tool from within a dialog box (such as Levels, Curves, etc.), hold 
down the Shift key. Alt+Shift-click on a sampler to delete it. 

34. Place a color sampler with the Eyedropper tool [ I ] by Shift-clicking on the canvas. 

35. Access the Color Sampler while using any paint tool by holding down both Alt and Shift. 

36. The Eyedropper tool [ I ] allows you to copy the hexadecimal value of a color to the Clipboard. 
Simply right-click over the desired color (in the image window) and choose Copy Color as HTML 
from the context menu. You may then paste the color value into your favorite editor. 

Note: You may also copy the current color as HTML (e.g. COLOR="#448CCB") by choosing Copy 
Color as HTML from the Color palette menu (  ). 
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PATH & SHAPE TOOLS 

37. The table below provides several hotkeys that are useful for working with paths:

1 Equivalent to clicking the Stroke Path button (  ) at the bottom of the Paths palette. 

2 Equivalent to clicking the Path to Selection button (  ) at the bottom of the Paths palette. 

3 These keys (omitting Ctrl and Enter) also work when clicking on the Path to Selection button 
(  ) at the bottom of the Channels palette. 

HotKey Result

Enter stroke a visible path with current paint tool and options 1

Ctrl+Enter turn a path into a selection 2

Ctrl+Shift+Enter add the current path's selection to the existing selection 3

Ctrl+Alt+Enter subtract the current path's selection from the existing selection 3

Ctrl+Alt+Shift+Enter intersect the current path's selection with the existing selection 3

38. While using the Pen [P], Path Selection [A], or Shape [U] tool, you can press Enter or Esc to hide 
the current path. 

39. Enable the Magnetic Pen tool by turning on the Magnetic option in the Freeform Pen tool's 
[Shift+P] Options palette. Configure its behaviour via the Magnetic Pen Options drop-down button 
menu (  ). 

Tip: Toggle between the Magnetic and Freeform Pen tools by holding down the Alt key. 

40. Add arrowheads to the Line tool [U] (Shape tool) using the Geometry 
Options button (menu) in the Options palette. 

41. Use paths as tracing guides for the Rubber Stamp tool [S] to remove 
such things as wires and power lines from images. 

42. Use the Add [ + ] (  ) or Subtract [ - ] (  ) buttons in the Options palette to invert a path (i.e. to 
turn a Reveal All (clipping) path into a Hide All (clipping) path and vice versa). 

Note: You must first select the path(s) using the Path Component Selection Tool [A]. 

43. Here are some useful shortcuts for use with the Pen [P] and Path Selection [A] tools:
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Pen Tool [P] Result

Alt-click and drag node 
handle *

redirect second handle before placing next point

Ctrl-click and drag node 
handle *

redirect both handles before placing next point

Alt-click and drag create combination point (and redirect handle before placing 
next point)

Ctrl access Direct Selection tool

Ctrl+Alt access Path Component Selection tool

Alt-click on end point close path with corner point

Freeform Pen Tool [P] Result

Alt-click draw straight line / add a corner point

Ctrl-release close shape with straight line

Ctrl access Direct Selection tool

Ctrl+Alt access Path Component Selection tool

Direct Selection Tool Result

Ctrl+Alt-drag anchor point * access Convert tool

Ctrl access Path Component Selection tool

Alt-drag * duplicate selected sub-path

Path Component Selection Tool [A] Result

Ctrl+Alt-drag * duplicate selected sub-path

Alt-drag * duplicate selected path

Add Pen Tool Result

Alt access Remove Pen tool

Ctrl access Direct Selection tool

Alt-drag * duplicate selected sub-path

Ctrl+Alt access Path Component Selection tool

Remove Pen Tool Result

Alt access Add Pen tool

Ctrl access Direct Selection tool

Alt-drag * duplicate selected sub-path

Ctrl+Alt access Path Component Selection tool
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VISUALIZATION TOOLS 

* Add the Shift key to constrain motion to 45° increments. 

Convert Point Tool Result

Alt-click convert to combination point

Alt-drag * convert to corner point and redirect handle

Ctrl access Direct Selection tool

Ctrl+Alt-drag * duplicate selection sub-path

Ctrl+Alt-drag * duplicate selection sub-path

44. To avoid anti-aliasing along horizontal and vertical edges of the Rectangle and Rounded 
Rectangle Shape tools [U], turn on the Snap to Pixels option in the Geometry Options drop-down 
(in the Options palette). 

45. To combine two or more shapes into a single path, select the shapes with the Path Component 
Selection tool [A]. Then, select the desired shape blending options (in the Options palette) and 
press the Combine button. 

Use the shape blending options to add (  ) [ + ], subtract (  ) [ - ], intersect (  ) or exclude 

(  ) two or more overlapping shapes. 

46. To extract a simple object, try creating a path and then stroke the path with the Magic Eraser tool 
[E]. The nice thing about this technique is that you can continually refine and stroke the path until 
you are happy with the results - plus, you can save the path with your image. 

Note: The results of this technique are often unpredictable and typically not as good as those 
obtained by other, more conventional methods of extraction, such as using the Extract command 
[Ctrl+Alt+X]. 

47. Press the Space Bar to access the Hand tool [H] at any time. 

48. Access the Zoom tool [Z] at any time by holding Ctrl+Space to zoom in, and Alt+Space to zoom out. 
You can even drag out a region to magnify while holding down Ctrl+Space. 

49. Zoom in and out by using Ctrl+Plus ( + ) and Ctrl+Minus ( - ), respectively: have the window resize 
to fit by also holding down the Alt key (Ctrl+Alt+Plus and Ctrl+Alt+Minus). 

Note: You may also have the document window zoom to fit while using the Zoom tool [Z] by 
enabling "Resize Windows to Fit" in the Options palette. 

50. While the Measure tool [Shift+I ] is pretty handy for measuring distances 
(especially on a diagonal), you can also use it to measure angles (like a 
protractor). Make sure the Info palette [F8] (Window » Show Info) is visible; 
then use the Measure tool [Shift+I ] to drag / draw a line. Hold down the Alt key 
and drag a second line out from one of the end nodes (note the angle and 
length of the two lines in the Info palette). 

Tip: Move a measure line (or protractor) by dragging it with the Measure tool (you may even 
reposition the endpoints independently). Delete a measure line (or protractor) by dragging it off 
the canvas. 
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MISCELLANIOUS 

51. Alt-click on tool icons (in the toolbar) to cycle through the available tools. This is a little faster than 
holding the left mouse button down to wait for the tool list to pop up. 

Note: You may also right-click on a tool (in the toolbar) to see a list of the hidden tools (as well as 
their associated hotkeys). 

52. Press Enter (or double-click on a tool icon in the toolbar) to reveal the Options palette for the 
currently active tool. Alternatively, you may choose Window » Show Options from the menus to 
reveal the Options palette (Window » Show Options). 

Tip: Pressing Enter also highlights the first field in the Options palette (regardless of whether or 
not the Options palette is already visible) so that you may immediately enter a value or choose an 
option. 

53. To restore the default settings for one (or all) of the tools click on its icon on the left side of the 
Options palette (Window » Show Options) and choose Reset Tool (or Reset All Tools). A dialog 
box will appear to confirm that you wish to reset the tool(s). 

Tip: You may also restore all tools to their defaults via the Reset All Tools button in the General 
Preferences dialog box [Ctrl+K] (Edit » Preferences » General). A dialog box will appear to confirm 
that you wish to reset all tools. 

54. Use the following keys while using any of the paint or selection tools:

* Add the Shift key to constrain motion to 45° increments. 

HotKey Result

Ctrl access the Move tool [V]

Ctrl+Alt-drag * create duplicate of the current layer or selection

Ctrl+Alt+right-click select the top-most layer under the mouse pointer

Ctrl+Alt+Shift-right-click (un)link the selected layer to the active layer

Shift constrain movement to 45º increments

55. Using the Move tool [V], Ctrl-click to select the layer under the mouse. Add the Shift key to (un)link 
the selected layer to the active layer. 

56. Hold down the Ctrl key to temporarily invert the behaviour of the View » Snap [Ctrl+; ] option. For 
example, if the View » Snap option is turned on, hold down the Ctrl key to disable it and vice versa. 

Example: Hold down the Ctrl key to stop the Crop tool [C] from snapping to the image borders. 
Alternatively, you may stop the Crop tool from snapping by turning off View » Snap To » Document 
Bounds (or None); or turn off snapping altogether [Ctrl+ ; ] (View » Snap). 
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57. You can use the Crop tool [C] to enlarge, rotate and even to add perspective to the current 
document! To increase the canvas size, choose full screen mode [F] (using one of the Full Screen 
Mode buttons (  ) near the bottom of the toolbar), and then drag any side / node of the crop 
marquee beyond the canvas boundaries. Rotate the image by dragging anywhere outside the crop 
marquee. Add perspective to the cropped region by first enabling the Perspective option in the 
Options palette and then dragging any corner node. 

Note: To accept the crop results you may double-click inside the crop region, press Enter, right-
click on the image window and choose Crop, or click the Commit button (  ) in the Options 
palette. To cancel the crop, press Esc, right-click on the image window and choose Cancel, or click 
the Cancel button (  ) in Options palette. 

58. When specifying dimensions for the Marquee [M], Crop [C], Shape [U], and Type [ T ] tools, you 
may use a variety of different units including: px = pixels, in = inches, cm = centimeters, pt = points, 
pica = picas, and % = percentages. Simply type the number followed by one of the above 
abbreviations (e.g. 5cm, 50%, 2 pt, etc.) 

Note: Photoshop will also accept the full name of the above units (e.g. 5 centimeters), but it is 
much simpler to use the abbreviations! 
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COMMAND TIPS

KEYBOARD SHORTCUTS (HOTKEYS) 

1. Use Ctrl+Alt+Z (Edit » Step Backward) and Ctrl+Shift+Z (Edit » Step Forward) to step backward and 
forward though the history states (or use the History palette menu (  ) to access the step 
commands). Use these commands in conjunction with Undo [Ctrl+Z] (Edit » Undo) to cycle between a 
specific history state and the current state. 

2. The table below provides some very useful hotkeys for performing the Fill command (Edit » Fill) on 
the current layer / selection:

HotKey Result

Shift+Backspace open Fill dialog box (Edit » Fill)

Alt+Backspace fill with foreground color

Alt+Shift+Backspace fill with foreground color and preserve transparency

Ctrl+Backspace fill with background color

Ctrl+Shift+Backspace fill with background color and preserve transparency

Ctrl+Alt+Backspace fill from current history state

Ctrl+Alt+Shift+Backspace fill from current history state and preserve transparency

3. Use the hotkeys provided in the table below to quickly transform the current selection or layer:

HotKey Menu Command Result

Ctrl+T Edit » Free Transform free transform selection / layer

Ctrl+Alt+T Alt + Edit » Free Transform free transform with duplicate

Ctrl+Shift+T Edit » Transform » Again repeat previous transformation

Ctrl+Alt+Shift+T Alt + Edit » Transform » Again repeat transformation with duplicate

4. Use Window » Close All [Ctrl+Shift+W] to quickly close all open documents. A save confirmation 
dialog will appear for any files that have not been saved. 

5. Use the Revert command [F12] (File » Revert) to restore the current document to its previously 
saved state. 

6. Prior to version 6, Photoshop had a command called Save a Copy, that would save a duplicate, 
flattened version of the current document. Although the command is gone (in a way), the associated 
hotkey still works. Press Ctrl+Alt+S to display the familiar Save As dialog box, but note that the Save 
a Copy flag has been automatically checked. 
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ENHANCED FUNCTIONALITY 

7. Use the following keyboard shortcuts to extend the functionality of the Layer » Merge command:

For linked layers, the following keys are different:

Command HotKey Result

Merge Ctrl+E merge the current layer with the layer below

Stamp Down Ctrl+Alt+E merge a copy of the current layer with the layer below

Stamp Visible Ctrl+Alt+Shift+E merge a copy of all visible layers into the current layer

Merge Visible Ctrl+Shift+E merge all visible layers into the current layer

Command HotKey Result

Merge Linked Ctrl+E merge all linked layers into the current layer

Stamp Linked Ctrl+Alt+E merge a copy of all linked layers into the current layer

8. If you have recently copied an image to the Clipboard, Photoshop will automatically insert the 
dimensions of the Clipboard image when you create a New Document [Ctrl+N] (File » New). To 
bypass this feature and recall the last settings, hold down the Alt key [Ctrl+Alt+N] (Alt + File » New). 

Tip: To insert the dimensions (as well as resolution and color mode) of any open document into the 
New Document dialog box, choose its name from the bottom of the Window menu. 

9. To straighten a crooked image, use the Measure tool [Shift+I ] to draw a line along what should be a 
horizontal or vertical line (the edge of the image, a doorframe, across the eyes of a person in a 
portrait, etc.), and then choose Image » Rotate Canvas » Arbitrary: the correct Angle and Direction 
will appear. Press the OK button to apply the rotation. 

Tip: The angle of the Measure tool [Shift+I ] is also used (for the current layer / selection) 
automatically when you choose Edit » Transform » Rotate. 

Note: You can also use the Crop tool [C] to rotate and crop an image in one step. Select the Crop 
tool [C] and draw a rectangular region. Use the crop handles to scale the marquee, and drag 
outside the marquee to rotate it: press Enter to crop the image. 

10. Use Layer » New » Layer via Copy [Ctrl+J] (or Cut [Ctrl+Shift+J]) command to perform a copy (or 
cut) and paste in one operation, and have the copied (or cut) elements pasted into the same 
position from which they were copied. 

Tip: Add the Alt key to display the Layer Properties dialog box for the Layer via Copy [Ctrl+Alt+J] 
(Alt + Layer » New » Layer via Copy) and Cut [Ctrl+Alt+Shift+J] (Alt + Layer » New » Layer via Cut) 
commands. 
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11. If you crop your image using Image » Crop, you will lose all pixels outside the crop boundaries. To 
crop your image without losing any data, use the Crop tool [C] with Cropped Area set to Hide (in 
the Options palette). 

Tip: You may also use Image » Canvas Size to crop the image without losing any data (unless you 
are in Indexed mode). Photoshop will warn you that some clipping will occur, but for some reason it 
does not: all "cropped" data will be preserved outside the canvas boundaries! 

Tip: Use the Image » Reveal All command to increase the canvas size and reveal the entire image. 

12. Stamp Down a copy of the current layer into the layer below by pressing Ctrl+Alt+E (Alt + Layer » 
Merge Down). 

Merge a copy of all visible layers into the current layer (or Stamp Visible) by holding down the Alt 
key while selecting Merge Visible [Ctrl+Alt+Shift+E] (Alt + Layer » Merge Visible). 

13. In the Liquify dialog box [Ctrl+Shift+X] (Image » Liquify), hold the Shift key while clicking the OK 
button to temporarily save the current mesh (to a file called C:\Temp\Liquify.tmp). To (re)load the 
mesh file (with your image), hold the Shift key while launching the Liquify command. 

Note: The C:\Temp\ folder must already exist on your system to take advantage of this feature. 

14. To print the current document using the default print settings (without confirmation), press 
Ctrl+Alt+Shift+P (Alt + File » Print One). 

15. Use the Trim command (Image » Trim) to remove any redundant background pixels from graphics 
that are destined for the web. 

16. Allowing Photoshop to merge all layers (flatten) when converting between modes (e.g. from RGB to 
CMYK) will produce better results than without merging. 

Tip: For the best results, use the Convert to Profile command (Image » Mode » Convert to Profile) 
for all mode conversions. 

17. To duplicate the current document without being prompted for a name (and have "copy" 
automatically appended to the filename), hold the Alt key and choose Image » Duplicate. 

18. Use the Edit » Fade command [Ctrl+Shift+F] to change the opacity of a floating selection or a 
selection that you have recently filled (with the Edit » Fill command [Shift+Backspace] or Paint 
Bucket tool [G]). 

19. To rasterize all vector layers in the current document simultaneously, choose Layer » Rasterize » 
All Layers from the menus. 

20. To change the resolution of an image without changing the dimensions, turn off the Resample 
Image option in the Image Size dialog box (Image » Image Size). 

21. Use the View » New View command for additional views of the current canvas. Each view may be 
independently magnified, scrolled, and even soft-proofed. All changes made in one view will 
automatically appear in the other views. 

This command is especially useful for small / detailed work, like icons. You can draw in one view at 
1600% magnification while seeing the actual size of the image in a separate view - without having 
to constantly zoom in and out. 
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TIPS FOR BLENDS, ADJUSTMENTS, FILTERS & STYLES

BLENDING MODES 

ADJUSTMENT LAYERS 

1. You can cycle through layer blending modes by using Shift+Plus ( + ) (cycle forward) and 
Shift+Minus ( - ) (cycle backward). Also try Alt+Shift+Letter (where Letter is one of the letters listed 
below) to quickly change the blending mode. 

Note: The above hokeys also affect the blending mode of the currently active paint tool, so if you 
wish to change the blending mode of the active layer, be sure to switch to the Move tool [V] or one 
of the selection tools first. 

N = Normal K = Darken Q = Behind 1

I = Dissolve G = Lighten L = Threshold 2

M = Multiply E = Difference R = Clear 3

S = Screen X = Exclusion W = Shadows 4

O = Overlay U = Hue V = Midtones 4

F = Soft Light T = Saturation Z = Highlights 4

H = Hard Light C = Color A = Saturate 5

D = Color Dodge Y = Luminosity J = Desaturate 5

B = Color Burn  P = Pass Through 6

Only applicable to:   1. Paint tools   2. Indexed mode   3. Dodge and Burn tools [O]   4. Line [U] and Bucket [G] 
tools on multi-layered images   5. Sponge tool [O]   6. Layer sets 

2. By default the Curves dialog box [Ctrl+M] (Image » Adjust » Curves) is only 171 pixels wide: 
however, you can click on the maximize (  ) / minimize (  ) button to toggle the grid size between 
256 pixels and 171 pixels wide. For greater accuracy, use the larger grid, since you have control 
over all 256 shades of gray in the image (compared to 171 shades by using the small grid). 

Tip: Hold down the Alt key to change Auto button into an Options button (and the Cancel button into 
a Reset button). 
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3. The table below details some of the features and equivalent hotkeys available in the Curves dialog 
box [Ctrl+M] (Image » Adjust » Curves):

HotKey Result

Alt-click on grid toggle grid between 10% and 25% gradations

Ctrl+Z undo last change

Ctrl-click delete selected point(s)

Ctrl+D deselect all points

Shift-click select multiple points

Ctrl+Tab / Ctrl+Shift+Tab activate next / previous point

Arrow keys ( , , ,  ) move curve point(s) by 1%

Shift+Arrow keys ( , , ,  ) move curve point(s) by 4%

Ctrl-click on image add color point to the composite curve

Ctrl+Shift-click on image add color point to all curves

P toggle preview on / off

L load curve

S save curve

M smooth curve

C activate channel menu

Ctrl+Tilde ( ~ ) select composite curve

Ctrl+Number select individual curve (e.g. Red, Magenta, etc.)

4. In the Levels dialog box, hold down Alt while you drag the black (left) or white (right) Input Levels 
sliders to adjust the levels in Threshold mode. This is also referred to as a "clipping display", since it 
visually demonstrates which colors will be clipped. 

5. Here is a real time-saver for adding adjustment layers (Layer » New Adjustment Layer » Adjustment 
Layer): simply click on the New Fill or Adjustment Layer icon menu (  ), at the bottom of the 
Layers palette, and select the type of adjustment layer you wish to add. 

Tip: Hold down the Alt key when choosing a fill or adjustment layer to display the Layer Properties 
dialog box. 

Tip: You can shave a few bytes off the size of a PSD by deleting any unused channels associated 
with Fill / Adjustment Layers - which are added by default. 

6. In the Hue/Saturation dialog box [Ctrl+U] (Image » Adjust » Hue/Saturation), you may: 
l Move the current range to a new location by Ctrl-dragging the color bar in the dialog box. 
l Add colors to the current range by Shift-clicking or dragging in the image window. 
l Subtract colors from the current range by Alt-clicking or dragging in the image window. 
l Edit all colors by pressing Ctrl+~ (tilde). 
l Press Ctrl + 1  6 to edit a predefined color range. 
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FILTERS 

7. To limit the influence of an adjustment layer, place it (and any associated layers) into a set and 
change the set's blending mode from Pass Through [Alt+Shift+P] to Normal [Alt+Shift+N]. The 
adjustment layer will only apply to the layers within the set. 

8. Adjustment layers may be used to emulate a duplicate layer. Choose an adjustment layer to add, 
and when the dialog box appears, accept the default values by pressing OK. Then, change the 
blending mode of the adjustment layer for the desired effect: Multiply [Alt+Shift+M] to darken, Screen 
[Alt+Shift+S] to lighten, or Hard Light [Alt+Shift+H] to increase contrast. If the effect is too extreme, 
simply lower the opacity of the adjustment layer. 

Note: To add an adjustment layer, use the New Fill / Adjustment Layer button (  ) at the bottom 
of the Layers palette, or choose Layer » New Adjustment Layer » Adjustment Layer from the menus. 

Note: Emulating duplicate layers with adjustment layers produces a file that is approximately 30% 
smaller than one that contains a "real" duplicate layer! 

9. In the Curves dialog box, you can use the Pencil tool (  ) at the bottom of the dialog box to draw a 
freehand curve. Shift click with the Pencil tool to draw straight lines. Use the Smooth button [M] to 
remove any abrupt changes in the curve. 

10. Click on the double arrow (  ) in the Curves dialog box to toggle between percentage (0-100%) 
and intensity (0-255). 

11. To reapply the last filter, use Filter » Last Filter [Ctrl+F]. To reapply a filter with new settings, add 
the Alt key (Ctrl+Alt+F or Alt + Filter » Last Filter). 

Tip: Fade the effects (and change the blending mode) of the last filter (or adjustment), by pressing 
Ctrl+Shift+F (Edit » Fade Last Filter). 

12. To achieve better results with the Unsharp Mask filter (Filter » Sharpen » Unsharp Mask), try 
applying it twice using a smaller Amount (%) setting. 

Example: Instead of applying Unsharp Mask once at an amount of 150%, use an amount of 60% 
twice. 

13. A common sharpening technique is to convert an image to Lab mode and then sharpen the 
Lightness channel. Instead, try the following technique to achieve nearly identical results without 
the image degradation associated with mode conversion. Apply Filter » Sharpen » Unsharp Mask 
and then choose Edit » Undo [Ctrl+Z]. Then, choose Edit » Fade Unsharp Mask [Ctrl+Shift+F] and 
choose Mode: Luminosity to reapply the filter. 

Note: You may also wish to check out Robert Barnett's Ultra Sharpen Pro plugin. 

14. Unfortunately, if you try to apply the Lens Flare filter (Filter » Render » Lens Flare) to a new 
(empty) layer, you will get an error. So, instead of duplicating or flattening your image, try the 
following technique: 

1. Add a New Layer [Ctrl+Shift+N] (Layer » New » Layer) 
2. Fill [Shift+Backspace] (Edit » Fill) the layer with black (by choosing Use: Black in the Fill dialog 

box) 
3. Set the blending mode of the layer to Screen (at the top of the Layers palette) 

http://www.ultrasharpen.com/
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STYLES & EFFECTS 

4. Render the lens flare on the new layer (Filter » Render » Lens Flare) 

Note: The above technique also works when applied to a layer filled with 50% gray 
(R128,G128,B128) and a blending mode of Hard Light. 

Tip: To specify the exact origin of the Lens Flare (in pixels), Alt-
click anywhere in the Lens Flare dialog box to display the 
Precise Flare Center dialog box. 

Tip: If you increase the canvas size, apply the above technique, 
and then return the canvas to its original size, you will be able 
to move the lens flare layer around on the canvas. 

Tip: To render a lens flare at a specific location (or size) on the canvas, draw a selection before 
applying the filter. 

15. Hold down the Alt key when choosing Filter » Render » Clouds to increase the contrast of the 
clouds. 

16. While applying a filter, you can click on the proxy view (preview window) in the filter dialog box to 
toggle between the before and after views. 

Tip: Ctrl-click in the proxy view to zoom in, or Alt-click to zoom out. 

Note: Unfortunately, the above tips do not work in all filter dialog boxes. 

17. Use the following tips for enhanced control within the Lighting Effects dialog box (Filter » Render » 
Lighting Effects): 
l Alt-drag a light to duplicate it 
l Press Delete to quickly delete a light 
l Shift-drag a node (on the light's perimeter) to change the area of influence without changing 

the lighting angle 
l Ctrl-drag a node (on the light's perimeter) to change the lighting angle without affecting the 

area of influence 

18. Like so many other filters, the Lighting Effects filter only applies to the active layer. To have the 
filter affect the entire document, Alt-click on the New Layer icon (  ) [Ctrl+Shift+N], choose Hard 
Light from the Mode drop-down and turn on the option labelled "Fill with Hard-Light neutral color 
(50% gray)". Finally, choose Filter » Render » Lighting Effects and the filter will appear as though it 
is affecting all the underlying layers. 

Note: This technique also work well with other filters (e.g. Lens Flare). 

19. Use Filter » Other » Maximum to decrease the width and height of an object on the current layer. 
Similarly, use Filter » Other » Minimum to increase the width and height of an object. 

20. With the Layer Style dialog box open, drag in the image window to visually adjust the distance and 
angle of the layer style. 

Note: Hold down the Shift key while dragging to constraint the distance and angle to 45º 
increments. 
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21. Hold down the Shift key while rotating the Angle wheel (in the Layer Style dialog 
box) to constraint the light source angle to 15º increments. 

22. Image operations such as scaling and rotating the canvas have no effect on any associated layer 
styles. Either flatten the image prior to performing these operations, or manually adjust the styles 
afterward. 

23. If you scale your image using the Image » Image Size command, your styles will not be scaled (i.e. 
all numerical values will remain constant). To scale the styles in your image, choose Layer » Layer 
Style » Scale Effects and enter the percentage by which you scaled your image. 

Note: You may scale your image and styles simultaneously by changing the image's resolution in 
the Image » Image Size dialog box. 

24. To remove all layer effects from a layer, hold the Alt key and double-click on the layer's effect icon 
(  ); or, from the menus, choose Layer » Layer Style » Clear Layer Style. 

Tip: To disable an individual effect, do one of the following: 
l hold down the Alt key and select the style by name from the Layer » Layer Style submenu 
l hold down the Alt key and select the style by name from the Layer Style icon menu (  ), at 

the bottom of the Layers palette 
l uncheck the style's Apply flag in the Layer Style dialog box 

25. Use the following technique to apply the same layer style (effect) to multiple layers simultaneously: 
1. Link all layers to which the layer style is to be applied 
2. Define (or choose an existing) layer style for one of the linked layers 
3. Right-click on the layer's style symbol (  ) and choose Copy Layer Style from the context 

menu 
4. Right-click again (on any of the linked layers) and choose Paste Layer Style to Linked 

26. Drag-and-drop effects to quickly copy them from one layer to another. To copy all effects from one 
layer to another, drag the topmost "layer" (labeled Effects) and drop it onto the desired layer. To 
copy an individual effect, drag-and-drop only the appropriately named effect (e.g. Drop Shadow, 
Outer Glow, etc.). 

Note: Dragging-and-dropping all effects (via the Effects "layer") will replace any existing effects 
that may exist on the destination layer. Dragging effects individually (by name) will add them to any 
existing effects on the destination layer. 

Note: You may also delete effects (individually or all together) by dragging them onto the delete 
icon (  ) at the bottom of the Layers palette. 

27. To adjust the fuzziness for the layer blending options (on the Blending Options page of the Layer 
Styles dialog box), Alt-drag the Blend If slider triangle(s). Once a triangle has been split, the Alt key 
is no longer required to move the fuzziness sliders. 

28. To save only specific styles (or brushes, gradients, etc.), choose Edit » Preset Manager, then 
select Styles from the Preset Type menu. Select a style (use the Shift key to select more than 
one), then click the Save Set button to save the selected style(s) as a preset. 

29. Use Fill Opacity (accessed from the Advanced Blending options in the Layer Styles dialog box) to 
change the opacity of the pixels on the current layer without changing the opacity of the actual 
layer. This useful for controlling the opacity of the pixels on the current layer independent of any 
applied styles. 
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30. The link status of a layer mask (or clipping path) may be used to influence the behaviour of layer 
styles. When a layer mask is linked to the current layer, the associated style is only applied to the 
visible pixels (i.e. the layer mask affects both the layer and the style). Alternatively, when the mask 
is unlinked, the style affects the entire layer (i.e. the mask has no influence on the layer style and, 
as a result, some of the style may appear "clipped" by the mask). 

31. Press Ctrl+Z in the Styles dialog box to undo the last change made using a slider (e.g. Opacity, 
Size, etc.). 

32. Drag a layer style (Effects) from one layer and drop it onto 
another to replace the style of the destination layer. Drag and 
drop an individual effect to add it to the destination layer. 

33. To add multiple styles to the active layer, Shift-click on the 
desired styles in the Styles palette. 

34. The default behaviour of the Paste Layer Style command is to 
replace the current Style. However, if you wish to add a 
previously copied layer style to the current layer, hold the Alt 
key and choose Layer » Layer Style » Paste Layer Style from 
the menus. 
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LAYER TIPS

LAYERS 

1. Hide / reveal all layers by Alt-clicking on the visibility icon (  ) of the desired layer. 

2. Unlink all layers from the current layer by Alt-clicking on the current layer's paintbrush icon (  ). 

3. Change the opacity of the currently active tool or layer by using the number keys (on the keyboard 
or on the number pad). Press "1" for 10% opacity, "5" for 50%, and so on: use "0" for 100% opacity. 
Numbers pressed in succession, such as "85", will result in an opacity of 85%. 

Note: The above hokeys also affect the opacity of the currently active paint tool, so if you wish to 
change the opacity of the active layer, be sure to switch to the Move tool [V] or one of the selection 
tools first. 

4. Alt-click on the Trash icon (  ), at the bottom of the Layers palette, to quickly delete layers 
(without confirmation): this also works with channels and paths. 

Tip: This technique also works for layer masks and clipping paths: click on an appropriate thumbnail 
and then Alt-click on the Trash icon (  ) to delete the mask or path without confirmation. 

5. Ctrl-click the Delete Layer icon (  ), at the bottom of the Layers palette, to simultaneously delete 
all linked layers. 

Tip: Ctrl+Alt-click the Delete layer icon (  ), to delete all linked layers without confirmation. 

Note: This tip will not work if all layers are linked together, because it is not possible to delete every 
layer in an image (i.e. at least one layers is required in any given image). 

6. With the Move tool [V] as the current tool (or while holding down the Ctrl key), right-click anywhere 
on the canvas for a list of the layers under the mouse pointer (ordered from top-most to bottom-
most): select a layer-name from the list to make it the active layer. 

Tip: If you get into the habit of naming layers in lower case and sets in upper 
case (or vice versa), you'll be able to easily distinguish the two when selecting 
layers or sets via the right-context menu. 

Tip: Add the Alt key (Alt-right-click) to automatically choose the top-most layer 
under the pointer. Alternatively, you may turn on the Auto Select Layer option in 
the Options palette (while the Move tool [V] is selected). 

Tip: Add the Shift key (Alt+Shift-right-click) to link / unlink the top-most layer that intersects with the 
current layer. 

7. Ctrl-click (or drag) with the Move tool [V] to automatically select (or move) the top-most layer under 
the mouse pointer. Ctrl+Shift-click (or drag) with Move tool [V] to link (or move) the top-most layer 
with the current active layer. 

8. Ctrl-click on the New Layer button (  ) or New Set button (  ), at the bottom of the Layers 
palette, to have the new layer or set inserted below the current layer or set. Ctrl+Alt-click to reveal 
the dialog box for the new layer or set to be added. 
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LAYER SETS 

9. Alt-double-click on a layer-name (in the Layers palette) to display the Layer Properties dialog box 
(i.e. to rename a layer). 

Tip: Alt-double-click on a Background layer to turn it into a regular layer (named "Layer 0") without 
confirmation. 

10. To lower the opacity for just a portion of a layer, make a selection, and press Shift+Backspace (or 
choose Edit » Fill from the menus) to access the Fill dialog box: set the blending mode to Clear, 
and set to the opacity as desired for the selected region. 

Another approach is to clear [Backspace] (Edit » Clear) the selected region, establish the desired 
history state, and then restore the contents of the selected region using the Fill command 
[Shift+Backspace] (Edit » Fill) with the Contents set to History and the opacity set as desired. 

11. By default, shapes are accompanied by a Color Fill layer. To change this, choose a new fill / 
adjustment layer from the Layer » Change Layer Contents submenu. 

12. Use the following keyboard shortcuts for moving and navigating through layers:

HotKey Result

Alt+ [ / ] activate previous / next (visible) layer

Alt+Shift+ [ / ] activate bottom / top-most (visible) layer

Ctrl+ [ / ] move layer down (backward) / up (forward)

Ctrl+Shift+ [ / ] move layer to bottom (back) / top (front)

13. To drag multiple layers between documents, first link them together, then use the Move tool [V] to 
drag them from one document window into the other. 

Note: You cannot drag multiple layers from the Layers palette into another document (even if they 
are linked together) - this will only move the selected layer. 

14. Duplicate a layer by dragging it onto the New Layer button (  ) at the bottom of the Layers 
palette; or choose Duplicate Layer from the Layers palette menu (  ). 

15. Here is a neat trick: use Ctrl+J (Layer » New » Layer via Copy) to duplicate the current layer (when 
there is no active selection). 

16. Alt-drag a layer onto the New Layer icon (  ) at the bottom of the Layers palette to duplicate 
the layer into a new document. 

17. Changing the blending mode and / or opacity of a layer set affects all layers within the set 
(effectively treating all layers inside as a single layer). 

18. To simultaneously place multiple layers into a Layer Set, first link the layers and then choose New 
Set From Linked from the Layer palette menu (  ); or choose Layer » New » Layer Set From 
Linked from the menus. 

Tip: Hold down the Alt key while choosing New Set From Linked to skip the dialog box (and use the 
Layer Set's default name and properties). 
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(CLIPPING) GROUPS 

19. To lock the transparency (  ), image / pixels (  ), position (  ), or all of these (  ), for all 
layers within a set, choose Layer » Lock All Layers in Set. 

Tip: Press the foward slash key ( / ) to toggle the current lock settings on or off. 

20. To release all layers from a set (i.e. delete the set without deleting the layers inside), activate the 
layer set and Ctrl+Alt-click on the trash icon (  ) or Ctrl-drag the layer set onto the trash icon 
(  ). Alternatively, click the trash icon (  ) and choose Set Only from the resulting 
confirmation dialog box. 

21. Duplicate a layer set (including all the layers inside) by dragging it onto the New Layer Set button 
(  ) at the bottom of the Layers palette; or choose Duplicate Layer Set from the Layers palette 
menu (  ). 

22. To create a new document from a layer set, Alt-drag the set onto the New Layer Set icon (  ) at 
the bottom of the Layers palette; then, in the dialog box that appears, choose New from the 
Document drop-down menu. 

23. To remove the bottom-most layer(s) from a layer set, drag the 
layer thumbnail (in the Layers palette) to the left. 

24. To duplicate multiple sets (and / or groups), first link the 
desired sets together. Then, duplicate the document and use 
the Move tool [V] to drag the desired sets back into the original 
document. You may then discard the duplicate document. 

25. You can add clipping paths (vector masks) and / or traditional layer masks to a layer set. Set 
masks affect all layers within the set. This allows you to have up to four masks affecting any given 
layer: a layer mask and a clipping path applied via both the layer and the set. 

26. A fast way to combine several layers into a group is to first link them together, then select Group 
Linked [Ctrl+G] (Layer » Group Linked). You may then unlink the layers if you wish. 

Note: You can also Merge [Ctrl+E] (Layer » Merge Down) multiple visible layers using the same 
technique (because, the Merge Down command becomes Merge Linked when the current layer is 
linked to other layers). 
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MASKS & CHANNELS 

 

27. Alt-click between layers (in the Layers palette) to group them 
together. This is handy when several layers are linked together, 
and you only want to group specific layers together (since the 
Group with Previous command changes to Group Linked when 
the current layer is linked to other layers). 

28. Here is a slick way to rearrange / reorder multiple layers, simultaneously (within the Layers 
palette): Group [Ctrl+G] (Layer » Group with Previous) the desired layers together, drag the group 
(up or down) into its new position within the Layers palette, and then Ungroup [Ctrl+Shift+G] (Layer 
» Ungroup) them again. 

Tip: Alternatively, you could combine the desired layers into a layer set and then move the entire 
set (up or down) within the Layers palette. 

29. Click the Add Mask button (  ), at the bottom of the Layers palette, to add a mask that reveals 
the current selection (Layer » Add Layer Mask » Reveal All). Alt-click on the Add Mask button 
(  ) to add a mask that hides the current selection (Layer » Add Layer Mask » Hide All). 

30. To create a mask for the current layer that represents the contents of the current layer, drag-and-
drop the layer onto the Add Mask button (  ) at the bottom of Layers palette. Alt-drag-and-drop 
the layer onto the Add Mask button (  ) to add a mask that hides the contents of the current 
layer (i.e. the mask is the inverse of the current layer). 

31. To copy a layer mask from one layer to another, first select the layer that you want to apply the 
mask to (and ensure that it does not already have a layer mask); then drag the layer mask 
thumbnail from another layer onto the Layer Mask icon (  ) at the bottom of the Layers palette. 

Tip: The above technique also works for copying a layer clipping path for one layer to another. 

32. Below is a table of hotkeys for working with layer masks:

HotKey Result

Alt-click layer mask thumbnail edit / reveal layer mask

Shift-click layer mask thumnail toggle layer mask on / off

Ctrl-click mask (or press Ctrl+Alt+ \ ) load layer mask as selection

Ctrl+Shift-click layer mask thumbnail add to current selection

Ctrl+Alt-click layer mask thumbnail subtract from current selection

Ctrl+Alt+Shift-click thumbnail intersect with current selection

Alt+Shift-click (or press Backslash [ \ ] ) view layer mask in rubylith mode (color)

Ctrl+Backslash ( \ ) switch focus from layer to layer mask

Ctrl+Tilde ( ~ ) switch focus to layer
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PATHS 

33. By default, (the first nine) channels have hotkeys associated with them. You may use these 
hotkeys (see the table below) to load the selection of a channel. Here are the hotkeys 
corresponding to some common color modes:

RGB Mode: CYMK Mode: Index Mode:

Ctrl+Tilde ( ~ ) = RGB
Ctrl+1 = Red
Ctrl+2 = Green
Ctrl+3 = Blue
Ctrl+4 = Other Channel

Ctrl+9 = Other Channel 

Ctrl+Tilde ( ~ ) = CYMK
Ctrl+1 = Cyan
Ctrl+2 = Yellow
Ctrl+3 = Magenta
Ctrl+4 = Black
Ctrl+5 = Other Channel

Ctrl+9 = Other Channel 

Ctrl+1 = Index
Ctrl+2 = Other Channel

Ctrl+9 = Other Channel 

34. While in Quick Mask mode [Q] (  ), use the Tilde key (~) to toggle the view between rubylith and 
channel mode (grayscale). 

35. Alt+Ctrl-click the New Channel button (  ), at the bottom of the Channels palette (Window » 
Show Channels), to add a new Spot Color channel (based on the current selection). 

36. To save a copy of the Quick Mask as an alpha channel, duplicate the Quick Mask layer by 
dragging it onto the New Channel button (  ) at the bottom of the Channels palette (Window » 
Show Channels). 

37. Turn off all paths easily by clicking on the empty area of the Paths palette (under the path layers). 

Tip: Toggle paths on / off by pressing Ctrl+Shift+H (View » Show » Target Path). 

38. Alt-click on the Fill Path (  ), Stroke Path (  ), Load Path as Selection (  ) and Make 
Path from Selection (  ) icons (bottom of the Paths palette) to see a list of available tools and / 
or options. 

39. To convert the active path into a layer clipping path, Ctrl-click the Layer Mask icon (  ) at the 
bottom of the Layers palette; or choose Layer » Add Layer Clipping Path » Current Path. 

Ctrl+Alt-click the Layer Mask icon (  ) to add a layer clipping path which hides the contents of 
the active path; or choose Layer » Add Layer Clipping Path » Hide All. 

Note: If the current layer already contains a layer mask, the Ctrl key is not required to add a layer 
clipping path. 
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40. Here are several hotkeys associated with layer clipping paths:

HotKey Result

Click layer clipping path thumbnail edit / reveal layer clipping path

Shift-click layer clipping path thumbnail toggle layer clipping path on / off

Ctrl-click layer clipping path thumbnail load layer clipping path as selection

Ctrl+Shift-click clipping layer thumbnail add to current selection

Ctrl+Alt-click clipping layer thumbnail subtract from current selection

Ctrl+Alt+Shift-click thumbnail intersect with current selection

41. To add a shape as a clipping path for an existing layer, Ctrl-click on the Add Mask icon (  ), at 
the bottom of the Layers palette, and then draw the desired shape using the Shape tool [U]. 

42. Hover over the thumbnail for a layer clipping path (in the Layers palette) to temporarily display the 
associated path in the document window. The path will disappear again after you move your 
mouse off the thumbnail. 
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TIPS FOR GUIDES & RULERS

GUIDES 

1. While dragging guides, hold down the Alt key to switch between vertical and horizontal guides. Alt-
click on an existing vertical guide to change it into a horizontal guide, and vice versa. 

Note: Guides are created by dragging them out from the document rulers, so ensure that the rulers 
are turned on [Ctrl+R] (View » Show Rulers). 

2. Dragging guides with the Shift key held down will force them to snap to the ruler increments / 
markings. 

3. To prevent guides from snapping to canvas boundaries and layers objects, hold down the Ctrl key 
while dragging them. 

4. Double-click on guides to open the Guides & Grid Preferences [Ctrl+K, Ctrl+6] (Edit » Preferences » 
Guides & Grid). 

5. Use paths to create curved or diagonal guides. Simply draw a path using the Pen tool [P] and use it 
as a guide while drawing or painting (the path will remain visible). 

Tip: Use the Show Target Path command [Ctrl+Shift+H] (View » Show » Target Path) to toggle the 
visibility of a path. 

6. Guides snap not only to the edges (left, right, top and bottom) of the active layer or selection, but 
also to the vertical and horizontal centers of the current layer or selection. The opposite is also true: 
you may snap a selection or layer to an existing guide (either by edge or center). 

Note: Guides do not snap to the Background layer. Also, be sure that Snap [Ctrl+ ; ] (View » Snap) 
and Snap To Guides (View » Snap To » Guides) are turned on for the above tip to work. 

Tip: Find the center of the canvas by filling a new layer and snapping a guide to the vertical and 
horizontal centers. 

7. To add guides at a specific location on the canvas, use the View » New Guide command. This is 
especially useful for placing guides from within an action. 

Example: Click here to download an action that finds the canvas center by placing guides at 
positions 50% horizontal and 50% vertical. 

8. Use the View » Show » Show Extras Options dialog box to set which screen objects are toggled on / 
off when you choose View » Show Extras [Ctrl+H]. 

9. Use the View » Lock Guides command [Ctrl+Alt+;] to stop guides from flipping with the canvas when 
you choose Image » Rotate Canvas » Flip Horizontal or Flip Vertical. 

file:///C:/Graphics/WebPage/print/downloads/CanvasCenter.atn
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RULERS 

 

10. Double-click on the Rulers [Ctrl+R] (View » Show Rulers) to open the Units & 
Rulers Preferences [Ctrl+K, Ctrl+5] (Edit » Preferences » Units & Rulers). 

Tip: You can also select a new unit of measurement from the Cursor Coordinates 
pop-up menu on the Info palette [F8] (Window » Show Info). 

 

11. Center the ruler origin anywhere on the canvas by dragging from the top-left 
corner (where the rulers meet). Reset the origin to its default position by 
double-clicking on the top-left corner. 
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ACTION & BATCH TIPS

ACTIONS 

1. To play just one step within an action, choose the step and Ctrl-click on the Play button (  ), at 
the bottom of the Actions palette [F9] (Window » Show Actions). 

Note: To change the parameters of a particular command step, double-click on the step to reveal 
the associated dialog box: any new values entered will automatically be recorded. 

2. To begin playback from a specific step of an action, simply choose the desired step and press the 
Play button (  ), at the bottom of the Actions palette [F9] (Window » Show Actions). 

3. If you are recording an action that might be used on different canvas sizes, be sure to switch your 
ruler units to percentage. This will ensure that all commands and brush strokes are recorded 
relative to the canvas size - and not based specific pixel coordinates. 

Tip: To quickly change the ruler units, right-click on the Rulers [Ctrl+R] (View » Show Rulers) and 
select the desired unit of measurement. You may also access the ruler settings by double-clicking 
on the rulers, or by choosing Edit » Preferences » Units & Rulers [Ctrl+K, Ctrl+5] from the menus. 

4. While recording / editing an action, you may insert a menu command (which might otherwise be 
unavailable), by choosing Insert Menu Item from the Actions palette menu (  ). 

Tip: This is also a great way to keep action steps generic (i.e. the menu commands will not be 
recorded with predefined parameters). 

5. Press Ctrl+Alt and choose Save Actions from the Actions palette menu (  ) to save all actions to a 
text file. This is very useful for reviewing or printing the contents of an action. 

Note: The text file cannot be reloaded into Photoshop. 

6. One really powerful aspect of actions is the ability to have them play other actions (even from 
different action sets). This feature is ideal for actions that contain repetitive command segments that 
could be segregated into action "subroutines" (thereby making the action easier to edit and 
maintain). While recording an action, choose another action and press the play button (  ): the 
play command is recorded as an action step (Play action "Name" of Set "Name" ) in the current 
action. 

7. Use the File » Automate » Create Droplet command to save an action as a droplet. A droplet is a 
small executable file that will automatically launch Photoshop and apply the designated action to any 
images that you drop onto it. 

8. Organize your actions by creating subfolders within the default Photoshop Actions folder 
(C:\Program Files\Adobe\Photoshop 6.0\Presets\Photoshop Actions\ - assuming a default 
install on a PC). Photoshop will still find these actions and even make them available from the Action 
palette menu (  ). 

Note: Prefix actions subfolders (or even individual actions) with a tilde (~) to disable them. 
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BATCH PROCESSING 

9. If you run an action but do not like the results, you have to undo all the steps that the action 
performed. Instead, create a snapshot (via the New Snapshot button (  ) in the History palette) 
before running an action; you may then click on the snapshot to revert the image back to state it 
was in before the action was executed. 

Tip: ImageReady treats actions as single steps in its History palette so you can undo actions in one 
step. 

10. Alt-drag an action step within the Actions palette [F9] (Window » Show Actions) to duplicate it. 

11. To include the creation of a path within an action, first create the path (before recording the 
action): then, with the path selected, begin recording and choose Insert Path from the Actions 
palette menu (  ). 

12. Select non-contiguous action steps using the Shift key. Use the Ctrl key to range select contiguous 
action steps. You may then move, copy, duplicate, delete, or even play the selected steps! 

Note: You may only select multiple steps within a single action. 

13. To improve the performance of batch processes (File » Automate » Batch), reduce the number of 
saved history states (in the General Preferences [Ctrl+K] (Edit » Preferences » General)) and 
deselect the Automatically Create First Snapshot option in the History Options (History palette 
menu » History Options). 

14. To batch-process multiple folders in a single batch, enable the Include All Subfolders option, and 
create shortcuts within the source folder to all folders you would like to have processed. 

15. To batch-process multiple actions, create a new action and record the batch for each action that 
you would like to process. Then run a batch-process using the newly created action. 

Tip: You may also use this technique in conjunction with tip 15, above. 

16. To change the default Web Contact Sheets (File » Automate » Web Photo Gallery), edit the HTML 
files located in C:\Program Files\Adobe\Photoshop 6.0\Presets\WebContactSheet\. You may 
even create your own HTML files and place them in their own folders. Your template will then 
appear in the Web Photo Gallery dialog box (without having to restart Photoshop). 

Note: It is always a good idea to make a backup of any files that you are going to change: 
however, you can always restore them from the Photoshop installation CD. 
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CONFIGURATION TIPS

PREFERENCES 

1. In the Edit » Preferences » Saving Files [Ctrl+K, Ctrl+2] you can set the number of recent files to 
display in the File » Open Recent submenu to a number between 0 and 30. Don't tell anyone, but 
Photoshop secretly keeps track of the last 30 files regardless of the number you specify: it just 
displays the number of entries that you specify. In fact, you can increase the number of recent files 
to be displayed and see the results immediately (in the File » Open Recent menu). 

2. Photoshop requires a scratch disk that is at least three to five times the size of the largest image 
that you intend to work on - regardless of the amount of RAM you have. 

Example: If you are working on a 5MB image, you should have at least 15MB to 25MB of hard drive 
space and RAM available. 

3. If you do not allocate enough scratch disk space, Photoshop's performance could suffer. The 
amount of RAM used Photoshop is limited by the available scratch disk space. So, if you have 1GB 
of RAM and tell Photoshop to use 75% of that (or 750MB), but only have 200MB available on the 
designated scratch disk, then the most RAM that Photoshop will use is 200MB. 

Note: To get optimum performance from Photoshop, set your Physical Memory Usage [Ctrl+K, 
Ctrl+8] (Edit » Preferences » Memory & Image Cache) between 50%-75%. 

Note: You should never assign Photoshop's Scratch Disk [Ctrl+K, Ctrl+7] (Edit » Preferences » 
Plug-Ins & Scratch Disks) to same drive as your Operating System (e.g. C:\), since your this will 
force Photoshop and your OS to compete for the available resources - thereby decreasing 
performance. 

4. Holding the Ctrl and Alt keys while launching Photoshop will allow you to change Photoshop's 
Scratch Disk Preferences before it loads. 

5. To reset all preferences to their defaults, press (and hold) Ctrl+Alt+Shift immediately after launching 
Photoshop (or ImageReady). A dialog box will appear to ask for confirmation. 

6. Normally, when you select a history state and then change the image, all states below the active 
state are deleted (or, more accurately, replaced by the current state). However, if you enable the 
Allow Non-Linear History option (from the History Options in the History palette menu), you may 
select a state, make a change to the image, and the change will be appended to the bottom of the 
History palette (instead of replacing all the states below the active state). You can even delete a 
state without losing any of the states below it! 

Note: The color of the horizontal lines between history states indicate their linearity. White dividers 
indicate linear states and black dividers indicate non-linear states. 

Note: Not only is a non-linear history very memory intensive, it can also be very confusing! 

7. Use the following Image Preview options [Ctrl+K, Ctrl+2] (Edit » Preferences » Saving Files) to save 
custom icons and preview images with your Photoshop documents: 

Always Save: saves a custom icon and an image preview (on the Photoshop Image tab of the 
image's Properties dialog box) with your image. 

Note: Enabling Image Previews typically increases the file size by about 2KB. 

Ask When Saving: allows you to manually toggle the Thumbnail option in the Save As dialog box. 
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CUSTOMIZATION 

Note: This option does not really "ask when saving",; it simply makes the Thumbnail option available 
when saving your image(s). 

Never Save: disables image previews and custom icons. This option also disables the Thumbnail 
option in the Save As dialog box. 

Tip: You can also toggle the creation of image previews via the Generate Thumbnail option located 
on the Photoshop Image tab of the image's Properties dialog box. 

8. An alternative to deleting unwanted plugins (.8be), filters (.8bf), file formats (.8bi), etc., is to prefix 
their filenames (or containing folders) with a tilde ( ~ ). Photoshop will ignore any files or folders 
beginning with a tilde ( ~ ). 

Example: To disable all "Digimarc" plugins, rename the folder to "~Digimarc". 

9. You may customize the "File » Jump To" and "File » Preview In" menus with Photoshop / 
ImageReady by creating shortcuts to your favorite applications within the Helpers folder: 

C:\Program Files\Adobe\Photoshop 6.0\Helpers\ 

Note: The above path assumes a default installation (for Windows). 

Add your favorite graphics application(s) to Photoshop's "File » Jump To" submenu by creating a 
shortcut in the "Jump To Graphics Editor" folder. 

To add your own HTML editor(s) to ImageReady's "File » Jump To" submenu, create a shortcut to 
the desired application(s) within the "Jump To HTML Editor" folder. 

To include your preferred browser(s) in ImageReady's "File » Preview In" submenu (or  button - 
in the toolbar), create a shortcut within the "Preview In" folder. 

Note: You may need to restart Photoshop / ImageReady for the applications to be displayed in their 
respective menus. 

Tip: Choosing a browser from the "File » Preview In" 
submenu (or Preview In button), assigns that browser as the 
default [Ctrl+Alt+P]. The designated browser takes effect 
immediately and persists the next time you launch 
ImageReady. 

Note: Although you may include additional graphic applications in the "File » Jump To" submenu for 
both Photoshop and ImageReady, you cannot reassign their default graphic applications. 
ImageReady's default graphics application [Ctrl+Shift+M] (  ) is Photoshop, and Photoshop's 

default graphics application [Ctrl+Shift+M] (  ) is ImageReady. 
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MISCELLANIOUS 

10. To force Windows (especially for 95 / NT) to use a specific monitor profile, do the following: 

1. Remove Adobe Gamma Loader from Start Menu » Startup 
2. Establish the Path\Name of the ICM profile to be used (most likely in C:\WinNT\System32

\Color\) 
3. Run RegEdit (using Start Menu » Run) and navigate to the following entry:

HKEY_LOCAL_MACHINE » Software » Adobe » Color » Monitor » Monitor0 
4. Create a New Key called Monitor Profile 
5. Enter the Path\Name of the profile (from step 2) into the Monitor Profile key 

Note: After installing this profile, do not run Adobe Gamma again since it will reinstall the Adobe 
Gamma Loader (into Start Menu » Startup). 

11. To free up memory you may choose Edit » Purge » Histories, but be warned that this will clear the 
history states of all open documents. 

Note: To purge the history states of the active document (only), hold the Alt key and choose Clear 
History from the History palette menu (  ). This will purge all history states without changing the 
image. 

Warning! The above commands cannot be undone. 

12. To calculate the file size of an image, use the following equation: 

     File Size = Resolution 2 x Width x Height x Depth / 8192 (bits/KB)

For 24-bit images at screen resolution (i.e. 72dpi) use: 

     File Size = Width x Height x 3 / 1024 

Tip: Divide by 1024 (KB/MB) to determine the file size in Megabytes. 

13. To ensure accurate histograms in the Levels dialog box, turn off the "Use cache for histograms" 
option in Edit » Preferences » Memory & Image Cache [Ctrl+K, Ctrl+8]. 

14. To create a Web-safe color, ensure that the R, G, and B components of the color are multiples of 
33 hexadecimal (or 51 decimal). For example, any of the following values are acceptable: 00 (0), 
33 (51), 66 (102), 99 (153), CC (204), FF (255). 



Steps
Scale

5
0.25
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15. Since the compression algorithms used for both JPEG and PNG work on blocks of 8 square pixels 
(i.e. 8 pixels wide by 8 pixels high), the file size of the image could be reduced by a few percent if 
the overall dimensions are divisible by 8. 

16. When reducing (or enlarging - although you should avoid up-sampling unless absolutely 
necessary) the size of an image, reducing in steps will preserve more of the image detail. This 
technique is often referred to as "Step Interpolation". Use the following formula to figure out the 
required step size: 

Step Size =  x 100% 

Example: To scale an image by 25% (0.25) in 5 steps, the calculation would be: 

Step Size =  = 0.758 x 100% = 75.8% 

Therefore, you would need to scale the image five times at 75.8% to end up with an image that is 
25% of its original size. 

Tip: Actions, scripts and batch processes can be used to simplify and expedite the step 
interpolation process, especially where many steps or large numbers of images are involved. 
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TYPE TIPS

FORMATTING 

1. Here is a very useful tip for achieving added control over the rendering of small type. Double-click 
on an existing type layer (  ) to enter type / edit mode. Move the type in the image window (by 
holding down the Ctrl key) to cause the anti-aliasing to shift / rerender. Once you are pleased with 
the anti-aliasing, commit / accept the type changes (by pressing Ctrl+Enter). Finally, you may 
reposition the type as desired without affecting the anti-aliasing. 

Tip: Also try different anti-aliasing methods for the above tip. 

Note: You may adjust the anti-aliasing as often as you like by entering edit mode and moving the 
type. Once out of edit mode, you may move the type without affecting the anti-aliasing. 

2. Anti-aliased type may be rendered inconsistently at small sizes (or low resolutions). To reduce this 
inconsistency, turn off the Fractional Widths option (in the Character palette menu (  )). 

3. Hold the Alt key as you click or drag a text box to display a 
Paragraph Text Size dialog box. The dialog box will display the 
current text box dimensions: enter the desired values for the 
Width and Height. 

Note: Another alternative is to simply watch the Width (W) and 
Height (H) values in the Info palette [F8] (Window » Show Info) as 
you draw the text box. 

Note: If you continue to hold Alt key down after the mouse button has been depressed (and you 
begin to drag), the text box will be drawn from the center. Upon releasing the mouse button, the Text 
Box Size dialog box will appear. 

4. To convert point text to paragraph text (or vice versa), right-click with the Type tool [ T ] and choose 
Convert to Paragraph Text (or choose Layer » Type » Convert to Paragraph Text from the menus). 

5. To modify the properties of several type layers simultaneously (i.e. font, color, size, etc.), link the 
desired type layers together and hold the Shift key while changing the type properties. 

Note: This feature applies to changes performed in the Options palette (Window » Show Options), 
the Character palette (Window » Show Character), and / or Paragraph palette (Window » Show 
Paragraph). 

6. Despite the fact that both the Edit » Fill command and the Paint Bucket tool [G] are disabled for type 
layers, Alt+Backspace (fill with foreground color) and Ctrl+Backspace (fill with background color) still 
work! 

7. Using the Type tool [ T ], right-click on type layers (in the image window) to display a context menu 
with many useful formatting options. 

Note: The right-click menu that appears in ImageReady has many more options available than the 
one that appears in Photoshop. 

8. For fonts that do not have associated bold or italic equivalents, try using the Faux Bold and Faux 
Italic options in the Character palette menu (  ).

Tip: You may also access the Faux Bold and Faux Italic options by right-clicking on a type layer with 
the Type tool [ T ]. 
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ENHANCED FUNCTIONALITY 

9. Hold down both the Shift and Ctrl keys while scaling type / paragraph layers to change the size and 
leading simultaneously. 

10. While in type / edit mode, use the View » Show Extras [Ctrl+H] command to hide a text selection. 

11. To restrict the use of certain fonts to Adobe applications, place them in C:\Program 
Files\Common Files\Adobe\Fonts\ 

12. Use the following click (and drag) features for enhanced type-selection capabilities:

HotKey Result

Double-click (and drag) select word (and then select one word at a time)

Triple-click (and drag) select line (and then select one line at a time)

Quadruple-click (and drag) select paragraph (then select a paragraph at a time)

Quintuple-click select all characters in a bounding box

13. If you are experiencing problems (or even crashes) when Photoshop attempts to load, try deleting 
the adobefnt.lst file (in C:\Program Files\Common Files\Adobe\Fonts\ ). Deleting this file 
forces Photoshop to recreate its font list and possibly fix the problem. 

14. Photoshop's font family field (in the Type tool Options palette) has an auto-complete feature; so, 
instead of searching through the font list, simply type the first few characters of the desired font 
and Photoshop will complete the name. 

15. While in type mode, press Ctrl+T to display the Character and Paragraph palettes (or press the 
Palettes button in the Options palette). 

16. To create a text selection with the standard Type tool [T], turn on Quick Mask mode [Q] (  ), 
and then enter the desired text. After committing the text, it will automatically turn into a selection. 

17. To quickly change the font while using the Type tool [T], press the Enter key to highlight the font 
family field and then press the up / down arrow keys (or use the mouse wheel) to choose a font. 

18. Double-click on the thumbnail associated with a type layer (in the Layers palette) to highlight all the 
text on the current layer. This is equivalent to choosing Select All [Ctrl+A] from the context menu in 
edit mode. 

19. If you want to change the attributes for all text on the current type layer, it is not necessary to 
select the text: simply make the desired changes in the Character and / or Paragraph palette(s) 
and the type layer will be updated to reflect the changes. 
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KEYBOARD SHORTCUTS (HOTKEYS) 

20. Use the Enter key on the numeric keypad (on the right side of the keyboard), or Ctrl+Enter (on the 
main keyboard) to commit text changes. Press Esc to cancel / discard changes. 

Note: You may also use the Commit Changes button (  ) in the Options palette (Window » Show 

Options) to accept any type changes. Use the Cancel Changes button (  ) to discard any 
changes. 

21. Use the following Alt codes to add smart quotes to your text: 

Note: To enter Alt codes, hold down the Alt key and enter the number shown 
using the keypad (on the right side of the keyboard). 

Quote Alt Code

0145

0146

0147

0148

22. Use the Alt key sequences below to add the indicated special characters to your type layers:

Note: To enter Alt codes, hold down the Alt key and enter the number shown using the keypad (on 
the right side of the keyboard). 

Alt Code Symbol Name

Alt+0153 TM trademark

Alt+0169 © copyright

Alt+0174 ® registered

Alt+0176 ° degree

Alt+0149 • bullet

Alt+0183 mid dot

Alt+0133 … ellipse

Alt+0177 ± plus / minus

Alt+0247 ÷ division

Alt Code Symbol Name

Alt+0171 « left guillemet

Alt+0187 » right guillemet

Alt+0186 º superscript 0

Alt+0185 ¹ superscript 1

Alt+0178 ² superscript 2

Alt+0179 ³ superscript 3

Alt+0188 ¼ quarter

Alt+0189 ½ half

Alt+0190 ¾ three quarters

.
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23. The table below provides the navigation and selection hotkeys that are available while in edit mode 
(working with type):

HotKey Result

Ctrl+H hide selection

Ctrl+A select all type

Home / End move cursor to beginning / end of line

Shift+ Home / End select type to beginning / end of line

Ctrl+ Home / End move cursor to beginning / end of story

Ctrl+Shift+ Home / End select type to beginning / end of story

 / move cursor to previous / next character

Shift+  / select previous / next character

Ctrl+  / move cursor to previous / next word

Ctrl+Shift+  / select previous / next word

 / move cursor one line up / down

Ctrl+  / cursor to previous / next paragraph

Shift+  / select one line up / down

Ctrl+Shift+  / select one line up / down to end of line

24. Below is a table of hotkeys for controlling the relative positioning of type:

* If a text selection exists, these keys will adjust the tracking instead of the kerning. 

HotKey Result

Alt+  /  * decrease / increase tracking by 20/1000em

Ctrl+Alt+  / decrease / increase kerning by 100/1000em

Ctrl+Shift+ < / > decrease / increase type size by 2px (pt)

Ctrl+Alt+Shift+ < / > decrease / increase type size by 10px (pt)

Alt+  / decrease / increase leading by 2px (pt)

Ctrl+Alt+  / decrease / increase leading by 10px (pt)

Alt+Shift+  / raise / lower baseline by 2px (pt)

Ctrl+Alt+Shift+  / raise / lower baseline by 10px (pt)
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25. The table below provides hotkeys for controlling type / paragraph characteristics:

HotKey Result

Ctrl+Shift+C center-align type

Ctrl+Shift+L left-align type

Ctrl+Shift+R right-align type

Ctrl+Alt+Shift+A set leading to auto

Ctrl+Shift+Q set tracking to 0px (pt)

Ctrl+Shift+U toggle underlining on / off

Ctrl+Shift+K toggle all caps on / off

Ctrl+Shift+H toggle small caps on / off

Ctrl+Shift+ / toggle strikethrough on / off

Ctrl+Shift++ toggle superscript on / off

Ctrl+Alt+Shift++ toggle subscript on / off

Ctrl+Alt+Shift+H toggle hyphenation on / off

Ctrl+Alt+Shift+T toggle every-line composer on / off

Ctrl+Shift+X set horizontal scaling to 100%

Ctrl+Alt+Shift+X set vertical scaling to 100%

Ctrl+Shift+F justify paragraph (force last line)

Ctrl+Shift+J justify paragraph (left-align last line)
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IMAGEREADY TIPS

INTERFACE 

1. Some tools in the toolbar have other tools hidden beneath them - as 
indicated by a small arrow in the lower right corner of the tool button. 
These tools may be released (or "torn away") as separate toolbars 
by holding down the left mouse button on the tool button and 
choosing the bottom-most button in the popup (the one with 
downward-facing arrow on it). 

2. Press Ctrl+Y (View » Show View Mode) to cycle through the available document View Modes 
(Original, Optimized, 2-Up, and 4-Up). 

3. Drag any document view tab (e.g. Original, Optimized, 2-Up, or 4-Up) away from the document 
window to create a new view of the current image. 

Note: Alternatively, you may select View » New View from the menus. 

4. To duplicate the current document, hold the Alt key and drag the Original view tab away from the 
document window (or choose Image » Duplicate). 

5. Click the inverted arrow icon in the status bar (  ), at the bottom of each document window, to 
choose from a list of information options.

Note: In 2-Up and 4-Up view modes, an additional Zoom Level icon (  ) is added. 

6. The small caution symbol (  ) that occasionally appears in ImageReady is actually a Regenerate 
button - equivalent to the Regenerate command in the Optimize palette menu (  ). 

Clicking on the Regenerate button (  ) when it appears in the bottom-right corner of the image 
window (in the Optimized view) regenerates the view as defined by the settings in the Optimize 
palette [F10] (Window » Show Optimize). This icon will only appear when Auto Regenerate is turned 
off in the Optimize palette menu (  ). 

Click on the Regenerate bottom (  ) in the bottom-left corner of the Color Table palette (Window » 
Show Color Table) to (re)generate the color table associated with the current image (as defined by 
the settings in the Optimize palette). 

7. When creating layer-based image maps in ImageReady, note 
that the associated URL is displayed below the layer name in the 
Layers palette. 

8. To apply the optimization settings of the current slice to another 
slice, drag the droplet icon (  ) from the Optimize palette [F10] 
and drop it onto the desired slice in the image window. 
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ANIMATION 

ACTIONS 

9. The following table contains hotkeys for controlling the Animation palette [F11] (Window » Show 
Animation):

1 Using these hotkeys in conjunction with one of the following tools may produce undesirable results: 
Move tool [V] (will duplicate the pixels in the current layer or selection), Image Map Select tool [P] 
(will duplicate the active image map - or cause an error if none are selected), Slice Select tool [K] 
(will duplicate the active slice). 

2 You may also use Ctrl+. or Esc to stop the playback of an animation. 

HotKey Result

Alt+  /  1 goto previous / next frame

Alt+Shift+  /  1 goto first / last frame

Shift+Space Bar 2 start / stop animation playback

10. When creating / saving animations, enable the Transparency option in the Optimize palette [F10] 
(Window » Show Optimize) to see what effect it has on the file size - even if your animation does 
not contain any transparent regions. By combining transparency, frame disposal (see below), and 
the Optimize Animation options (see below), it is possible to significantly decrease the file size of 
the animation. 

Note: Ensure that the disposal method is set to Automatic (no icon) or Restore to Background 
(  ). To set the disposal method, right-click on a frame (in the Animation palette [F11] (Window » 
Show Animation)) and choose an option from the context menu. 

Note: The above technique only works if Bounding Box and / or Redundant Pixel Removal are 
enabled (from Animation palette menu » Optimize Animation). 

11. When choosing Paste Frames (from the Animation palette menu), ImageReady presents you with a 
dialog box that allows you to choose how and where the frames will be pasted and whether or not 
any duplicated layers should be linked (applies only to Paste Over Selection). To skip this dialog 
box and paste the frames using the default options (Paste Over Selection without duplicating any 
layers), hold the Alt key down when choosing Paste Frames. 

12. Here are two useful options that are hidden away in the Animation palette menu: 
l Add Layer To New Frames adds a new layer every time a new frame is added. 
l New Layers Visible In All Frames makes any new layers that you add visible in all frames of the 

animation (sort of like an automatic Match Layer Across Frames). 

13. When creating an action that includes styles (layer effects), each setting is recorded as a separate 
action step. To record the style in a single step, drag the style from the Layers palette [F7] 
(Window » Show Layers) into the Actions palette [F9] (Window » Show Actions). 
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COLOR 

14. Drag a droplet (  ) onto the Actions palette [F9] (Window » Show Actions) to create an action 
step (containing all the optimization settings of the droplet). Alternatively, you can select Insert Set 
Optimization Settings to Image Format from the Actions palette menu (  ). 

Tip: You can also drag a droplet onto a slice to apply the optimization settings to the slice. 

15. Drag a command from the History palette (Window » Show History) to the Actions palette [F9] 
(Window » Show Actions) to create an action step (with or without pressing the Record button). 

16. To organize your ImageReady actions, create subfolders inside of the default actions folder 
(C:\Windows\Application Data\Adobe\Photoshop\6.0\Adobe Photoshop 6 
Settings\ImageReady Actions\). All subfolders within this path will be loaded when ImageReady 
launches. 

17. If you rearrange the order of your actions in ImageReady's Actions palette, their order will be 
saved when you exit the program. 

18. ImageReady actions (ISA - ImageReady Script Action) are simple text / script files (much like 
JavaScript): you may edit them using a text editor (such as NotePad or TextPad). 

19. Like Photoshop, ImageReady also contains a Batch command, but it is hidden in the Actions 
palette menu (under Batch Options). 

20. Use the Eyedropper tool [ I ] to select a color from anywhere on the screen. Click inside the current 
image window, hold the mouse button down, and drag anywhere on the desktop (or even over 
another application window): release the mouse button to select the desired color. 

Note: This feature only works provided that ImageReady remains active (i.e. in the foreground). 

21. ImageReady allows you to select colors based on a selection marquee. Make a selection in the 
current image and choose Select All From Selection from the Color Table palette menu (Window » 
Show Color Table). 

22. To view the occurrence(s) of a color in the Optimized Image window [Ctrl+Y] (View » Show 
Optimized), click and hold the mouse button over a color in the Color Table palette (Window » 
Show Color Table). The selected color will remain temporarily inverted (until you release the 
mouse button). 

Tip: This also works for multiple selected colors! To view a contiguous group of colors, select a 
color and Shift-click and hold another color. For non-contiguous colors, Ctrl-click to select 
additional colors, then hold the mouse button to temporarily invert the selected colors. 

23. To copy the hexadecimal value of a color to the Clipboard, choose a color with the Eyedropper tool 
[ I ], then right-click over the image window and choose Copy Foreground Color as HTML from the 
context menu. You may then paste the color value into your favorite editor. 

Note: You may also choose Edit » Copy Foreground Color as HTML from the menus. 

24. In ImageReady, hold down Ctrl when you add a new color to convert the color table into a custom 
palette. 

http://www.textpad.com/
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TOOLS 

25. In ImageReady's Color palette [F6] (or Color Picker dialog 
box), you can click on the Web-safe symbol (  ) and drag 
around the outside of the icon to see the eight closest Web-
safe matches to the current color. Let go of the mouse to 
accept one of the colors. 

26. To select only Web-safe colors from ImageReady's Color palette [F6], choose Web Color Sliders 
from the Color palette menu (  ). This will force the color sliders to snap to increments of 33 
hexadecimal (or 51 decimal). 

Tip: Alt-drag the Web color sliders to select a non-Web-safe color. 

27. Use ImageReady's drag-and-drop text editing capabilities to perform a cut and paste 
simultaneously. Simply highlight some text with the Type tool [ T ], then drag and drop the text to 
the intended destination. 

28. Use the following keyboard shortcuts in conjunction with the Slice and Slice Select tools [K]:

HotKey Result

Ctrl toggle between Slice and Slice Select tools [K]

Shift select multiple slices / constrain movement to 15° increments

Alt-drag duplicate a slice (add Shift to constrain movement)

Ctrl+D deselect slice(s)

Ctrl+A select all slices

Ctrl+H hide all slices

29. In ImageReady, you can use the Slice tool [K] to resize 
multiple slices at the same time. First, select two or more 
contiguous (adjacent) slices by Shift-clicking with the Slice 
Select tool [K]. Then, drag the common boundary between 
the selected slices to resize both slices simultaneously. 

30. While creating a slice, you can hold down the Space Bar to move the slice: release the Space Bar 
to continue adjusting the size of the slice. 

31. In ImageReady, you can save, load and delete slice selections. To save the selected slices, 
choose Slices » Save Slice Selection from the menus. To load a previously saved slice selection, 
choose Slices » Load Slice Selection, and select the desired slice selection from the submenu. To 
delete a previously saved selection, choose Slices » Delete Slice Selection, and select the slice 
selection you want to delete from the submenu. 

Note: Deleting a slice selection does not delete the slices themselves. 
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COMMANDS 
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32. To see what your image / animation will look like on a PC / Mac, use the View » Preview submenu 
(and choose a display type). 

Note: To permanently adjust your image / animation, use Image » Adjust » Gamma. 

33. To center the current layer on the canvas, choose Layer » Set Layer Position and enter Horizontal: 
Center, 0 pixels and Vertical: Center, 0 pixels. You may also use the Set Layer Position command 
to align the current layer to any canvas edge or corner. 

34. Hold down the Alt key while choosing Image » Crop to display a dialog box with the option to Hide 
or Delete the area outside the crop region. 

35. Use ImageReady's Tile Maker filter (Filter » Other » Tile Maker) to create seamless tiles and 
background images. 

36. Use the Relative option in ImageReady's Canvas Size dialog box (Image » Canvas Size) to enter 
the amount by which you want to increase the canvas - instead of having to do the math in your 
head. 

Note: Unfortunately Photoshop does not have this option. 

37. Use ImageReady's View » Create Guides command to create multiple (evenly spaced) guides. 

38. The Layer » Set Layer Position command in ImageReady allows you to specify the exact position 
(absolute or relative) for a layer. 

39. Press F1 or Ctrl+/ (on the keyboard or keypad) to access Help in ImageReady. 
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