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RedCrab – The Calculator

The calculation software RedCrab was developed with the aim a calculator

made available that combines the function of a calculator with a text editor.

RedCrab enable the user to input a mathematical expression in a full-screen

editor, providing  input of mathematical symbols like fraction, roots e.t.c. The

positioning of the expressions on the page is arbitrary. The format must conform

to general mathematical rules.

Designed as a tool for daily use, useability has highest priority. Almost all

entries, regardless of whether values, variables, exponents, radical signs or

fraction lines can be written with the keyboard.

Comments and suggestions to the software and user manual are very welcome

and helpful for further developments and improvements. Feedback please email:

info@redchillicrab.com

System requirement

Minimum Pentium P4 and 250MB RAM. Operating system: Microsoft

Windows The following fonts: Courier New and Symbol must be installed in

your system. These fonts belonged to Microsoft Windows systems. No

installation of the software is required. You can just copy the software to your

system and starts the programs.

Calculation range: 1.7e 308 to 5e-324

Accuracy: 18 digits

Display : 15 digits



1.0 Mathematical Expressions

1.1 Basics

You can write your formula principle at any editor position. For the following

examples we usefully begin in the upper left 4
th

 or 5
th

  column in one of the first

lines. Input in the editor will be displayed in black letters. The output of the

calculator is printed in blue.

It must be written only a mathematical expression per line. Between

mathematical expressions must be either a blank line or in front of the

expression in the next line a colon in the first column must be set.

Example: x = a+12

a = 5

or x = a+12

     : a = 5

RedCrab distinguishes between two different formats at the input of

mathematical expressions: the single-mode and the extension mode. The single

mode allows  only the input of a single arithmetic problem, but is more flexible

than in the formatting of the extension mode.

Format in single mode: 

a+12

   or  x = a+12

   or  x
2
 = (a +12) 

2

The result is always written below the expression.

Format in the extension mode:

x=a+12

   or x=a+12 =



In the extension mode must always be left of the equals sign a single variable.

The result is written to the right of the task after the second equal sign. If the

right is no equal sign, is also output no result.

The mode is toggled with the <=> button in the toolbar above.

<=> off (gray) : Single mode

<=> on (blue) : Extension mode

!  The examples below are written using single mode.

1.2 Simple Addition

1. Enter the expression 17 + 4

2. For result press <Ctrl + Enter>

The <Ctrl+Enter>  key starts  Redcrab and  displays the result. Alternative click

the function panels Enter button.

The display shows:

17+4

21

The result is displayed below the expression, beginning in the same column.

Results are always displayed in blue.

1.3 Assignment Of Values

1. Enter the expression 17 + 4 + X

2. Enter the assignment X = 43

3. For result press <Ctrl + Enter>

RedCrab displays the result:  64



The display shows:

17+4+X

X=43

64

The assignment can be entered at any position below the expression

1.4 Equation

The same expression as above, however as an equation.

1. Enter the equation Z = 17 + 4  + X

2. Enter the assignment X = 43

3. Press <Ctrl + enter) to display the result

The display shows:

Z=17+4+X

X=43

Z=64

1.5 Exponent

The expression: c
2 
= a

2 
+ b

2
.

1. Enter the expression: c  <Ctrl + 2>   =  a   <Ctrl + 2>  +  b  <Ctrl + 2>

2. Press <Ctrl + Enter> to display result.

The keys <Ctrl + 2> write the exponent 2. With the keys <Ctrl + 3> you can

write the exponent 3. For use of any other values for exponents, press the

<Ctrl+6> keys to enter the supermode. Then enter the exponent value. Press

<enter> to leave supermode.



The display shows:

The example above includes no assignment for a and b, so RedCrab can only

eliminate the exponent of c. The following example shows the assignment and

its solution.

The display shows:

1.6 Subscript And Implied Multiplication

Enter the formula: XL = ωL

1. Press the following keys :  X   <Ctrl + _ >  L  <Enter>  =  <Ctrl + W>  L

2. Enter the assignment ω=2πf ;  press the keys : <Ctrl + W> = 2  <Ctrl + P>  f

3. Enter the assignment f = 2200

4. Enter the assignment L=0.8 10
-3

; press the keys : L = 0.8 10 <Ctrl + 6> - 3

<Enter>

5. Press the keys <Ctrl + Enter>

With the keys <Ctrl + underscore> you can switch Subscript on / off.

Alternative use <Enter> to leave Subscript region.

The Ctrl key shift the letters to the alternative font. The example above shows

that the keys <Ctrl + P> displayed the Hellenic letter Pi (π).



The display shows:

The example above show three important features of RedCrab: the subscript

mode, the implied multiplication and assignment of a formula to a variable

(ω=2πf).

Implied multiplication means you do not need to include the multiplication

operator

Example:  RedCrab interprets XL = ωL as  XL = ω ∗ L

RedCrab interprets a sequence of letters, for example, ab, as different variable.

Exclude subscript letters, for example XL.  Subscript letters always belong to the

variable on the left.

Example:

abc : a * b * c

3ab : 3 * a * b

2XL = 2 * XL

R1R2 = R1 * R2

Use the Escape mode if you want a sequence of letters for a single variable.

Read more about the Escape mode in the description below.



1.7 Fraction and Square Root

Enter a formula with a fraction and a square root.

1. Enter the fraction line an the numerator : f = <Ctrl + /> <Enter> 1 <Enter>

2. Enter the denominator : 2 <Ctrl + P> <Ctrl + 1> LC

3. Assignment  L : L=0.8 10 <Ctrl + 6> - 3

4. Assignment  C: C=4.7 10 <Ctrl + 6> - 6

5. Press <Ctrl + Enter> for result.

The display shows:

To write a fraction line press < Ctrl + / > (forward slash) key. Read more

information below about fractions in the description.

The keys <Ctrl + 1> write a root symbol at the cursor position, then mark the

range which should be below the root. Click the root symbol and the editor draw

the root line above the marked range. Read more information about square roots

in the description below.



2.0 The Toolbox

Picture 3.1

2.1 Fonts

The editor used the New Courier and Symbol fonts. They are usually included

with Windows operating system. New Courier is the default font. The Symbol

font includes Hellenic letters and special symbols.

You can toggle between the fonts by mouse click on the < a> and < π> buttons,

left on the toolbar, or press <Ctrl + .(dot)>  keys. The button of the activated

font is displayed in blue.

Usually the New Courier font is in use. Alternative font is generally needed for

certain Hellenic letter. Without switching the font you can type in single letter of

the alternative font by pressing the <Ctrl> key. Example: press <Ctrl+P> to

write the character π or <Ctrl+L> to write the letter λ. Conversely, if the Symbol

font is switched on,  press Ctrl key to use New Courier font.

2.2 Font Size

Next to the Font buttons the toolbox show the font size. You can change the font

size with use of the combo button at the right or write the new font size in the

box. The maximal font size is 512.



2.3 Superscript

Use Superscript to write an exponent. Toggle the Superscipt mode per mouse

click on the toolbox <a
x
> button. With the keyboard you can toggle with

<Ctrl+6> or <Shift+^>, the <Enter> key leave the Superscript mode.

2.4 Subscript

Toggle Subscript mode per mouse click on the toolbox <ax> button. The

underscore_ key and <Ctrl+_ (underscore)> toggles Subscript too. The <Enter>

key leaves the Subscript mode.

2.6 Escape

A mouse click on the  <Esc> button toggles the Escape mode. You can leave the

Escape mode with the <Enter> key. If the editor is in Escape and Superscript

mode the <Enter> key leaves Escape mode only.

Read below the description about Escape mode.

2.7 DEG / RAD

The < DEG > and < RAD > buttons select the input to a trigonometric function.

< DEG >: input must be in degrees.

< RAD >: input must be in radians.

The selected button is displayed in blue.



2.8 Exponent - EXP

If the <EXP> button switched on (displayed blue), the calculator write the result

as power of ten.

2.9 Decimal Digits

Next to the <EXP> button you can change the number of decimal digits in your

result. To change the decimal digits click the up/down button right or change the

number in the display. RedCrab stores different number of digits for fix- and

floating point results

2.10 Fix- / Floating point results

Choose between fix- and floating point results with mouse click on the < FIX > /

< FLT > buttons.

• FIX  : fix point

• FLT : floating point

2.11 Single And Extension Mode

The Single / Extension mode  is toggled with the <=> button in the toolbar.

RedCrab distinguishes between two different formats at the input of

mathematical expressions: the single-mode and the extension mode. The single

mode allows  only the input of a single arithmetic problem, but is more flexible

than in the formatting of the extension mode. More infomation about the modes

see above 1.1 Basics



3.0 Function Panel

The following part describes the Function panel button.

Alternative you can use the keyboard to execute the

panel functions. If you are not using the Function panel,

you can switch this off under the View menu.

Alternative function keys:

• F5 – Clear

• F6 – Reset

• F7 – Refresh

• F8 – Enter

Picture 3.2

It is very simple to write the mathematical function in the text editor without the

use of the function panel.  Example:  sin(x).  It is important that you write the

letter sin in Escape mode. Read the description about Escape mode below.

3.1 Clear

The Clear button prepares the Clear function. Simply press <Enter> to execute

the Clear function. Enter must be pressed not later than 2 seconds after Clear.

Clear clears the screen,  the main memory and the undo memory.

3.2 Reset

Reset clear all calculators output (displayed in blue). It don’t change the user

input.

3.3 Refresh

Refresh starts a display redraw.



3.4 Enter

Enter start the calculator and display the result. It’s equal to the <F8> and

<Ctrl+Enter> keys.

3.5 Mathematical Functions (Function Panel)

sin() sine

cos() cosine

tan() tangent

arcsin() inverse sine

arccos() inverse cosine

arctan() inverse tangent

deg() convert radian in degrees

rad() convert degrees in radians

cot() cotangent

exp() exponent to Euler's constant : 2.7182818284590452...

ln() natural logarithms to base  e (2,7182818284590452...)

log() logarithms base 10

log2() logarithms base 2

log8() logarithms base 8

log16() logarithms base 16

Extended Functions

e Euler's constant : 2.7182818284590452...

π constant PI: 3.1415....

ld() logarithms base 2

lg() logarithms base 10 (equal to log )

log10() logarithms base 10 (equal to log )



3.6 Operators

RedCrab uses the operators below:

+ Addition

-  Subtraction

* Multiplication

/ Division

DIV Integer number division without remainder.

MOD Returns the remainder of the division of  integer numbers

3.7 DIV

The DIV operator returns the result of a integer number division without

remainder. If there are floating point numbers are entered, the DIV operator cuts

the digits after the decimal point before executing the division DIV .

Example :

    11   DIV 3   = 3

11.2 DIV 3.9 = 3

3.8 MOD

The MOD operator returns the remainder of the division of two integer

numbers. If there are floating point numbers are entered, the MOD operator cuts

the digits after the decimal point before executing the division MOD

Example :

    11   MOD 3   = 2

    11.7 MOD 3.9 = 2



4.0 Symbol Panel

The Symbol Panel contains large bracket symbols.

You can write this symbols with the keyboard too.

But problem may arise by any non English

keyboard or language. In this case you can use the

Symbol Panel. If you have no problem, switch off

the Symbol panel in the View menu. Most time the

keyboard input is more comfortable. For more

information about the keyboard read below the

description about keyboard configuration.

  

     Picture 3.3

The Symbol panel contains extra large brackets which are not included in system

fonts. The following list shows the key codes for the English US keyboard:

• Ctrl + '9' ( Left round bracket

• Ctrl + '0' ) Right round bracket

• Ctrl + '[' [ Left square bracket

• Ctrl + ']' ] Right square bracket

• Ctrl + Shift + '[' { Left curly bracket

• Ctrl + Shift + ']'   } Right curly bracket



5.0 Keyboard

The keyboard inputs in the following description correspond to the English

keyboard and Windows regional and language option English-US. When using a

non-English keyboard or language, some functions are acquired with other key

combinations. This concern most of the <Ctrl> key functions. In the attachment

of this manual you will find pictures about key codes of different keyboards.

Read the description below about keyboard configurations.

Esc Switch to escape mode.

To exit escape mode: press enter key

or bracket open

-  Exit escape mode

-  Exit Superscript

-  Exit Subscript

-  Moves cursor to numerator, if this position is end of fraction

bar,

-  Moves cursor to denominator, if this position in the numerator

row.

Enter

-  Moves cursor to end of fraction, if this position at the

denominators row.

Enter + Ctrl Display result Equal to the Function  panels Enter

button

Enter + Shift Line feed- return : move the cursor to the first used column in

the next row

Ctrl + (Shift) switch to alternative font

Ctrl +  . Toggle ANSI / Symbol

font

Ctrl +  , Toggle on / off Subscript

Ctrl + _ Toggle on / off Subscript (equal Ctrl + ,)

Ctrl + Shift +  , Toggle on / off Superscript (exponent)

Ctrl + 6 Toggle on / off  Superscript (equal Ctrl +  Shift + ,)

Ctrl + 9 large round bracket open

Ctrl + 0 large round bracket close

Ctrl + [ large square bracket open

Ctrl + ] large square bracket close

Ctrl + Shift + { large curly bracket open

Ctrl + Shift + } large curly bracket close

Ctrl + / fraction line

Ctrl + 1 root

Ctrl + 2 Exponent 2

Ctrl + 3 Exponent 3

Ctrl + 4 Integral Formula

Ctrl + Shift + 4 Integral Symbol



Ctrl + 5 Function Symbol

Insert Insert a column at cursor position

Insert + Shift Insert a row at cursor position

Delete Delete a column at cursor position

Delete + Shift Delete a row at cursor position

Ctrl + Csr left Page left

Ctrl + Csr right Page right

Ctrl + Csr up Scroll up

Ctrl + Csr

down

Scroll down

Ctrl + Page up Move cursor to the first row of the screen

Ctrl + Page

down

Move cursor to the last row of the screen

F5 Clear - clear all,  to demand execution  confirm with  enter (F8)

F6 Reset – clear the output of the calculator

F7 Refresh – redraw the screen

F8 Enter

6.0 The Menu Bar

6.1 File.Open

Click Open on the File menu. In the  Navigation pane, click folder or drive  that

contains the file that you want to open. You can only load file that are saved

with RedCrab before, with the file extension *.rec.

6.2 File.Save

If you are saving a changed file click Save on the File menu or press Ctrl+Alt+S.

6.3 File.SaveAs



If you are saving the file for the first time use SaveAs on the File menu, the file

browser prompt for a file name.

6.10 Edit. Undo / Redo

You can undo and redo your action by clicking Undo or Redo on the Edit menu.

You can undo and redo up to 100 actions. Undo and Redo is not possible by

imported object like bitmaps.

6.11 Edit.Copy / Paste

With the Copy and Paste functions you can  copy  and insert data within

RedCrab or from/to external programs. The Copy function copy the selected

fields to the clipboard. Texts from/to external programs will posted as

unformatted ASCII text.

Within RedCrab the data are copied in format style. Exception: square root.

With Paste function only the symbol of the square root is inserted. The range

belonging to this field must be selected at the new position again. Hence errors

can be avoided , e.g. only the sub range square of a root is copied and inserted to

other position.

6.12 Edit.Paste To Box

For complex technical calculations, it may be useful to include technical

drawings to mathematical formulas. With Paste To Box on menu Edit you can

import images and formatted texts from external programs. The image or the

formatted text is inserted into a box and can be positioned freely. Multiple

images or text boxes can be inserted. The amount is limited only by resources of

your computer.

To change a box position, move the mouse pointer on a box, press the left

mouse button and pull with pressed mouse button the box into the desired

position.



To delete a box  click first on the Clear button on the function panel (or press

<F5> key) and click on the box to be deleted.

Information about the import of images and text files can be found below under

Menu Insert.

6.13 Text Box

Text boxes are always inserted in a preset size. You  can resize the box

according to text size. It is possible to edit the texts in the text box.

To edit text or the text box it must be activated first. Activate the text box with a

doubleclick of the left mouse button. The background of the activated text box

will displayed coloured and the text cursor is indicated.

To change the size of the text box, position the mouse pointer on the lower right

corner of the box and drag the box with pressed right mouse button to the

desired size. Information for editing text can be found below at Chapter text

editing.

If the editing of the box and text is completed, deactivate the box by

doubleclick with the left mouse button.

6.14 Text Editing

For editing of text the following table shows a list of keyboard instructions.

Keys Operations

Ctrl+Tab Tab

Ctrl+Number Pad 5 Select all

Ctrl+A Select all

Ctrl+E Center alignment

Ctrl+J Justify alignment

Ctrl+R Right alignment

Ctrl+L Left alignment

Ctrl+C Copy



Ctrl+V Paste

Ctrl+X Cut

Ctrl+Z Undo

Ctrl+Y Redo

Ctrl+'+' Superscript

Ctrl+'=' Subscript

Ctrl+1 Line spacing = 1 line.

Ctrl+2 Line spacing = 2 lines.

Ctrl+5 Line spacing = 1.5 lines.

Ctrl+' (apostrophe) Accent acute

Ctrl+` (grave) Accent grave

Ctrl+~ (tilde) Accent tilde

Ctrl+; (semicolon) Accent umlaut

Ctrl+Shift+6 Accent caret (circumflex)

Ctrl+, (comma) Accent cedilla

Ctrl+Shift+'

(apostrophe)
Activate smart quotes

Backspace delete previous character.

Ctrl+Backspace Delete previous word.

F16 Same as Backspace.

Ctrl+Insert Copy

Shift+Insert Paste

Insert Overwrite

Ctrl+Left Arrow Move cursor one word to the left.

Ctrl+Right Arrow Move cursor one word to the right.

Ctrl+Left Shift Left alignment

Ctrl+Right Shift Right alignment

Ctrl+Up Arrow Move to the line above.

Ctrl+Down Arrow Move to the line below.

Ctrl+Home Move to the beginning of the document.

Ctrl+End Move to the end of the document.

Ctrl+Page Up Move one page up.

Ctrl+Page Down Move one page down.

Ctrl+Delete Delete the next word or selected characters.

Shift+Delete Cut the selected characters.

Alt+X
Converts the Unicode hexadecimal value preceding the

insertion point to the corresponding Unicode character.

Alt+Shift+X
Converts the Unicode character preceding the insertion

point to the corresponding Unicode hexadecimal value.

Alt+0xxx

(Number Pad)

Inserts Unicode values if xxx is greater than 255.

Insertc ASCI values if xxx is less than 256

Ctrl+Shift+A Set all caps.

Ctrl+Shift+L Fiddle bullet style.



6.15 Edit.Cut/Delete

With functions Cut and Delete on the Edit menu the selected range on the

computing sheet is deleted. With Cut the range is copied  in the clipboard and

can be inserted in other position again.

6.20 View.Grid

You can show or hide gridlines. Use Grid on the View menu to switch the grid

on / off.

6.21 View.Function Panel

All functions on the Function Panel can also be input with keyboard. If you

don’t use the Function panel you can switch it off. Just click on Function Panel

on the View menu.

6.22 View.Symbol Panel

Toggle the Symbol panel  with click on Symbol Panel on the View menu.



6.30 Insert.Bitmap File

Load a graphic file. For complex technical calculations, it may be useful to

include technical drawings to mathematical formulas. Click Bitmap File in the

Insert menu to open the image file browser and select the image file. Only file

type Windows Bitmap (*. bmp) can be inserted. Inserted image is positioned on

the top left of the page. You can move it by clicking the left mouse button on the

image and drag, while holding down the mouse button, the image to the desired

position.

To delete a box, click first on the Clear button on the function panel (or press

<F5> key) and then click on the box to be deleted.

6.31 Insert.Text File

For documentation purposes, text files can be inserted in any position in text

box.

To load a text file click Text File on menu Insert. It opens a file browser to

select a file. Files of the type TXT (unformatted text) or RTF (Rich Text

Format) can be inserted.

The text is inserted in a text box positioned on the top left corner at the

calculation sheet. To move the text box, position the cursor on the text box and

press the left mouse key. Then drag the box in the desired position by holding

down the left mouse button. . Multiple text boxes can be inserted. The amount is

limited only by resources of your computer.

To delete a box, click first on the Clear button on the function panel (or press

<F5> key) and then click on the box to be deleted.

Text boxes are always inserted in a preset size. You  can resize the box

according to text size. It is possible to edit the texts in the text box. For

information about resize and edit textboxes read Textbox Editing above.



6.32 Insert.New Textbox

With NewTextbox on menu Insert an empty text box will be inserted. To input

text the box must be activated with a double click of the left mouse button. For

more information about text box editing read the capital Text Box above.

6.33 Insert.Textbox To Image

The function text Box To Image converts a text box into an image box. The

advantage of a graphics box is:

1) The texts cannot be changed .

2) The formatted text is displayed in original format (similar to a PDF file),

even if the displayed font is not installed on the user computer.

The function should only be used if it makes sense. By changing the format of

the file, the file size will be larger.

!Important : This function cannot be reversed !

6.34 Insert.Show Textbox

The function Show Text box in the menu Insert displayed all text boxes with a

coloured background. The function is helpful in allocating an empty text box or

showing the exact positioning.

6.40 Extras.Page Lock

With Page Lock on the menu Extras, the editors page will be blocked for

additional entries. This function protects unintentional changes made. For data

input the cells can be unlocked with Unlock Cell.



6.41 Extras.Cell Unlock

With Unlock Cell on menu Extras cells in a locked page, are unlocked for data

entry . Select the cells by mouse, then click Unlock Cell on menu Extras. The

unlocked fields are marked with an underscore.

To clear the unlocked cells select the cells by mouse, then click Unlock Cell on

menu Extras. The cells are locked now.

6.50 Option.Size

You can change the numbers of cells in a worksheet. Use the Size submenu on

the menu Option. The size can be changed only with an empty page. Once data

is input, this function is disabled.

You can choose between three size of worksheet:

1. 72 x 72 cells

2. 144 x 144 cells

3. 108 x 48 cells

6.51 Option.Keyboard

The keyboard input in this description refers to an English keyboard in the

country's setting English-US When using a non-English keyboard or language,

some functions are acquired with other key combinations. This concern most of

the <Ctrl> key functions.  If you have problems with the assignment of the keys,

click Keyboard in the Options menu. It opens with a list of alternative

keyboards, which differ significantly in important features of the English

keyboard. Here you select a keyboard that corresponds to your specification.

Attached you will find images about key codes of the alternative keyboards and

the occupancy of the Ctrl functions.

6.52 Option.Display Buffer

RedCrab works with a dual screen memory. This will  scroll faster and flicker is

avoided. However, this feature works only on new generation computers and



video cards. On older computers, it can lead to slower response to inputs. In this

case, it is convenient to click Display Buffer on Option menu to eliminate this

feature.



7.0 Work With RedCrab

7.1 Startup

After programm start RedCrab display an empty page, similar to an empty sheet

of paper. In its basic setting the size of the arithmetic field is 72 x 72 cells. This

corresponds approx. to one 12” or DIN A4 sheet with average type-size. The

size of the arithmetic field can be changed in the menu Option / Size to 108 x 48,

or  144 x 144 cells.

!  The size of the arithmetic field can be changed only with empty screen. After

input this function is blocked.

RedCrab store the current size in use. So after a new start of the programme the

previous setting will be displayed.

7.2 Write A Mathematic Expression

A mathematic expression can be written at any position. It is important that

enough space remains to express the result. Certainly, it is useful to begin

somewhere in columns / rows up on the left. RedCrab distinguishes between two

different formats during input of mathematical expressions: Single-Mode and

Extension mode. Single mode in comparison to extension mode allows only the

entry of a single mathematical problem, but is more flexible in formatting than

of the extension mode.

The mode is toggled with the <=> button in the toolbar above.

<=> off (gray) : Single-mode

<=> on (blue) : Extension Mode

7.3 The Single Mode

In single mode it does not matter whether the mathematical assignment  is

written as an equation or not. The expression 17 + 4 will display  the result 21.

The equation X = 17 + 4 displayed the result X = 21. The result is always



written below the expression. If calculation is carried out repeatedly, the results

are written below each other.

For mathematical tasks with variable following rule must be observed:

! In Single mode the assignment to variable must always below the formula.

Between each assignment and formula, there must be at least one blank line in

between, or the assignment must be marked with a colon in the first column.

Example 1:

x = a + b

a = 10

b = 12

Example 2:

x = a + b

: a = 10

: b = 12

7.4 The Extension Mode

In the extension mode, a single variable must always be left of the equal sign.

The result is written to the right of the assignment after the second equal sign. If

on the right is no equal sign, RedCrab displays no result.

Format in the extension mode:

x=a+12=

 or x=a+12

Several different tasks or expressions can be entered. By setting the right equal

sign, you can determine which results or intermediate results to be printed.



! The order of mathematical functions of the allocation is quite arbitrary.

Between each assignment or formula,there must at least one blank line in

between, or the assignments must be marked with a colon in the first column.

7.5 Fractions

Entering a fraction line: Press the keys <CTRL + /> (Ctrl + Slash) and a three-

character fraction bar will be displayed. By repeatedly pressing the keys the

fraction bar is extended by one character forward. In general, it is sufficient if

you continue entering data above and below the fracture line. When typing  the

numerator or denominator data, the fraction bar is automatically extended by the

editor as far as it is required.

The input of data is supported here by the text editor . If you have taken the

fraction line, the cursor is in the first column after the line. Press in this position

<Enter> key, the cursor moves over the slash to the first position of the

numerator. After entering the numerator, press again <Enter>, the cursor jump

to the first position of the Denominators. After entering the data  press <Enter>

again. The cursor jumping back into the column after the slash.

! The fraction bar must exceed at least 1 character front and rear .

Examples:

 123   wrong

 abc

 123  correct

  abc



7.6 Root

Set the root character with the keys <CTRL + 1> to the desired position. Then

mark the area which is to be included under the root. Finally set the cusor on the

root of character, the editor draws the root symbol over the marked area.

For one-line root calculation,the following steps apply:

1. Set root symbol with <CTRL + 1> .

2. Enter the data

3. Holding down the Shift key and with <Cursor-left> key  reposition to the root

sign.

The editor draws the root symbol over the marked area.

For multi-line data in the root (e.g., fractions):

1. Set root symbol with <CTRL + 1>.

2. Data entry.

3. Mark the area for the root with the mouse.

4. Click the mouse on the root symbol.

The editor draws the root symbol over the marked area.

In order to highlight the area, it is sufficient if the last column under the root is

marked.

To change the area under the root, highlight, as described above, the new field

and then click the cell of the root sign. The roots then marked the new area.

By double-clicking on the root symbol the root lines around the data is removed.

7.7  Escape Mode

RedCrab works as described above with implied multiplication. A sequence of

letters be regarded as a single variable and be multiplied. If it is necessary for a

variable or a function to use a name with more than one letter use the Escape

mode. The Escape mode is activated by pressing the ESC key. All these

characters are then interpreted as one word, until the Escape mode is switched



off . To cancel ESC, press Return or '('. The screen will be printed bold

characters in Escape mode.

If an Escape variable follow a bracket you must set an operator before the

bracket. Escape name followed by a bracket without operator is usually

interpreted as a function call.

For example: correct: sin (12 + a)

correct: six * (12 + a)

wrong: six (12 + a)

different Esc  names must be separated by SPACE  or operator, otherwise they

are interpreted as a word

For example: correct: apple * banana

correct: apple banana

wrong : applebanana

7.8 Integral

For calculating the area of a curvilinear region RedCrab provides termed

definite integrals. The Integral must be formatted as below:

The input of the integral is simple. Press the <Ctrl + 4> keys and RedCrab

display the complete integral formula on the screen shown above. Now you can

overwrite or  complete the formula as appropriate. See the example below.



The names of the variables are interchangeable. For example instead of <x> you

can chose  <t> , which does not change the value of the integral.

In complex calculations, the function (integrand) can be outsourced  and assign

with a reference variable.

For example:

In the example above, <z>  represents the function of the integral. The allocation

of <z> to the right of the equal sign, must always be enclosed in brackets.

In the example above, the integration limits <a,b> > have been overwritten with

values <0, 90 >.When overwriting the variables, it must be noted that as shown

in the example, only one-line concept can be used (without fraction) and the

term with no spaces must be written directly to the integral sign. The values of

the limits of integration may alternatively be assigned outside of the integral to

the variables  <a> and  <b>.

For example:

a=0

b=90

By default the subdivision of the calculation is in 360 units. The division can be

changed by the variable <d > when assigned a different value.

For example:

d=1000



Functions assigned to keyboard:

Integral (formula): <Ctrl + 4>

Integral symbol : <Ctrl + Shift + 4>

Function symbol : < Ctrl + 5>

Typical accuracy by a sinus calculation: 2/ d
2



Attachment

KeyCode Configuration

US-english

German



Italian

Brazil (Portoguese)


